[linux-dvb] Fwd: hauppauge nova-t stick driver problem... driver hacking?

José Oliver Segura primijos at gmail.com
Sat Dec 22 12:22:49 CET 2007

---------- Forwarded message ----------
From: José Oliver Segura <primijos at gmail.com>
Date: Dec 20, 2007 3:24 PM
Subject: Fwd: hauppauge nova-t stick driver problem... driver hacking?
To: linux-dvb <linux-dvb at linuxtv.org>

       related to this problem/dirty-hack, I've tried different things
("soft reinitialisations") and they didn't seem to work. In the file
dvb-core/dvb_frontend.c, in function dvb_frontend_ioctl, inside the
"case FE_SET_FRONTEND", I've tried different options before the
--------- End fwd message --------------------

       Hi all,

       I've some updates on this problem, maybe this can give some
light to any one with more expertise with these drivers: Right now,
I've achieved some more stability in the tuning of this driver by
adding a call to download/start firmware before each tuning and also
adding two msleep; msleep(250) before the call to tune and msleep
(750) before returning from ioctl routine. Also (very important, I
think) I have moved back again to version 1 firmware, and disabled RC
support in the frontend (since I use another remote that uses the same
range than the nova-t remote and seemed to interfere, leaving the
driver in a state in which it flooded the log file with lots of
"unknown code" messages... even when no key was pressed in the

       In this scenario, tuning seems more reliable, despite the fact
that there still being a couple of channels I cannot tune (no viterbi
bit observed with femon) and the fact that some channels still
presenting strange high "ber" values when they are not the first to be
tuned after a full reload (cold state) of the stick (these channels
present ber=0 unc=0 when they are the first to be tuned, but a couple
of zaps to another channel, and zap back again to them make the ber
value increase; with the current configuration only a couple of them
present a ber value growing enough to present also unc values
different from 0 and, thus, glitches in audio/video)

       Just as additional info: the couple of channels that cannot be
tuned at all (the ones without the viterbi bit), also cannot be found
with "scandvb". I was able to find them with "scandvb" some time ago,
with some combination -that I cannot remember- of driver/firmware. But
right now, I'm not able to find it with scandvb anymore.

       Does this give any light about this problem to anyone?


More information about the linux-dvb mailing list