[linux-dvb] [RFC] Should a DVB frontend report the board name?

hermann pitton hermann-pitton at arcor.de
Fri Feb 9 15:59:37 CET 2007

Am Donnerstag, den 08.02.2007, 10:31 +0100 schrieb Andrea Venturi:
> hermann pitton wrote:
> > Hi,
> > 
> > Am Mittwoch, den 07.02.2007, 10:07 +0400 schrieb Manu Abraham:
> >> On 2/7/07, hermann pitton <hermann-pitton at arcor.de> wrote:
> >>> Hi!
> >>> and the the cinergyT2 seems not to have a maintainer anymore.
> >> Is it broken or something like that ? unfortunately i don't have any
> >> hardware to test the same. If there are some users out there, who can
> >> provide feedback on the status, most probably it can be fixed in case
> >> it is broken.
> > 
> > Marc reported it non functional on Ubuntu 6.10 with its 2.6.17 kernel.
> > On FedoraCore6 it worked for him.
> > 
> > Thierry from the video4linux usbvision project seems to be the only one
> > else on the lists currently with such a device. He confirmed it working
> > on vanilla and even tested on vanilla, works.
> > The current v4l-dvb on this older kernels is not yet tested for it.
> > 
> > After it seemed there was also some precompiled module involved, I
> > thought we found it. Marc is now back with a clean install of v4l-dvb
> > and still doesn't get it to work since three weeks now.
> hi,
> i don't know if i'm getting on the right track. i missed the beginning
> of this thread.
> i see you speak of the cynergy T2. i do have it, so i can test any
> v4l-dvb tree, provided with some time.
> for example, i just tested this tree:
>   http://linuxtv.org/hg/v4l-dvb?ca=a8819e65be60;type=bz2
> on my vanilla kernel 2.6.18 on debian/unstable (i can provide the kernel
> config, if useful) the cinergy T2, with this tree, works:
>   usbcore: registered new driver cinergyT2
>   usb 5-5: USB disconnect, address 7
>   usb 5-2.1: new high speed USB device using ehci_hcd and address 8
>   usb 5-2.1: configuration #1 chosen from 1 choice
>   DVB: registering new adapter (TerraTec/qanu USB2.0 Highspeed DVB-T
> Receiver).
> let me know if i need to try something else..

Hi Andrea,

thanks for your support.

The cinergyT2 was meant here only to remember that Holger and Gerd once
had a discussion if linux-dvb should implement kernel i2c or not.
Later on it was a problem to get dvb-pll included and it looked like
Gerd should write endless out of tree kernel patches forever to get
hybrid stuff working. IIRC, he sent all mainline anyway.
and followups for the interested.

This time Manu is a step ahead with multiproto considering naming
conventions and v4l2 needs API changes to cover all the new hardware and
to sync with linux-dvb anyway. So Mauro has the hard part.

For Marc and the cinergyT2 on Ubuntu 6.10 latest is here.

We should return to the thread and Marc should report, if the LED is
still never on. Out of list I find reports that the device works on
Ubuntu 6.10, also several with the "usual" usb disconnect troubles, but
none with not at all. There is also no open bug at Ubuntu and v4l-dvb
compiles against the latest Ubuntu kernel without warnings and anything
for the cinergyT2, but that is all I can test so far.


More information about the linux-dvb mailing list