[linux-dvb] Lost frontend

Bryant, Dominic (UK) Dominic.Bryant at baesystems.com
Fri Feb 16 10:22:42 CET 2007

Can anybody help me with this?


-----Original Message-----
From: linux-dvb-bounces at linuxtv.org
[mailto:linux-dvb-bounces at linuxtv.org] On Behalf Of Bryant, Dominic (UK)
Sent: 07 February 2007 13:20
To: linux-dvb at linuxtv.org
Subject: [linux-dvb] Lost frontend

               *** WARNING ***

This mail has originated outside your organization, either from an
external partner or the Global Internet. 
     Keep this in mind if you answer this message. 

Hello, this is my first post to this (or any) mailing list, so sorry if
this is the wrong place for this or anything like that...

About a week ago I got a Kworld DVB-T 300U box.  I plugged it into my
Ubuntu 6.10 system and dmesg said that it couldn't find the firmware.  I
downloaded the firmware, put it in the correct place (/lib/firmware I
think), plugged in the DVB box, ran Kaffeine, scanned for the channels
and everything worked fine. It carried on working for the next couple of
days during which time I tried to install MythTV (which couldn't find
any channels).  The day after that I go to watch the TV using Kaffeine
and it doesn't work any more.  Dmesg now gives the following:

[17289667.668000] usb 5-6: new high speed USB device using ehci_hcd and
address 11 [17289667.800000] usb 5-6: configuration #1 chosen from 1
choice [17289667.800000] dvb-usb: found a 'KWorld Xpert DVB-T USB2.0' in
cold state, will try to load a firmware [17289667.844000] dvb-usb:
downloading firmware from file 'dvb-usb-adstech-usb2-02.fw'
[17289667.932000] usb 5-6: USB disconnect, address 11 [17289667.932000]
dvb-usb: generic DVB-USB module successfully deinitialized and
[17289669.684000] usb 5-6: new high speed USB device using ehci_hcd and
address 12 [17289669.816000] usb 5-6: configuration #1 chosen from 1
choice [17289669.816000] dvb-usb: found a 'KWorld/ADSTech Instant DVB-T
in warm state.
[17289669.816000] dvb-usb: will pass the complete MPEG2 transport stream
to the software demuxer.
[17289669.816000] DVB: registering new adapter (KWorld/ADSTech Instant
DVB-T USB2.0).
[17289669.816000] dvb-usb: no frontend was attached by 'KWorld/ADSTech
Instant DVB-T USB2.0'
[17289669.816000] input: IR-receiver inside an USB DVB receiver as
[17289669.816000] dvb-usb: schedule remote query interval to 150 msecs.
[17289669.816000] dvb-usb: KWorld/ADSTech Instant DVB-T USB2.0
successfully initialized and connected.

For some reason it is no longer attaching a frontand to the device. I've
searched everywhere, read the past 5 or 6 months of mailing list
archives and asked on the Ubuntu forum but not got anywhere.

Last night I even did a manual install of the v4l drivers even though I
shouldn't need to with my kernel (I thought it might help) but no
change.  Why would it suddenly stop working?  Please help as it was
great when it did work.

This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.

linux-dvb mailing list
linux-dvb at linuxtv.org

More information about the linux-dvb mailing list