[linux-dvb] Problem with local hg trees

e9hack e9hack at googlemail.com
Sun Feb 18 16:11:26 CET 2007


some time ago, I've created two local copies of the v4l-dvb repository. The command was "hg clone
http://linuxtv.org/hg/v4l-dvb". I've done many changes in one directory. From time to time, I've reverted all changes
with "hg revert" and I've updated the tree with "hg pull -u". If I run "hg pull -u" in both directories, I get:
pulling from http://linuxtv.org/hg/v4l-dvb
searching for changes
no changes found
The command "hg diff" shows no differences. It seems that both directories contains the same source code like the
repository on http://linuxtv.org/hg/v4l-dvb. If I run a normal diff between both directories, I get an output of 486
lines. 11 files have differences. It seems, that 'hg pull -u' doesn't work properly. What do I do wrong?

The attached file contains the output from diff.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: help.diff.bz2
Type: application/octet-stream
Size: 4474 bytes
Desc: not available
Url : http://www.linuxtv.org/pipermail/linux-dvb/attachments/20070218/2118e3d8/help.diff.obj

More information about the linux-dvb mailing list