[linux-dvb] Problem with local hg trees

e9hack e9hack at googlemail.com
Sun Feb 18 17:09:37 CET 2007

Manu Abraham wrote:
> On 2/18/07, e9hack <e9hack at googlemail.com> wrote:
>> Hi,
>> some time ago, I've created two local copies of the v4l-dvb
>> repository. The command was "hg clone
>> http://linuxtv.org/hg/v4l-dvb". I've done many changes in one
>> directory. From time to time, I've reverted all changes
>> with "hg revert" and I've updated the tree with "hg pull -u". If I
>> run "hg pull -u" in both directories, I get:
>> pulling from http://linuxtv.org/hg/v4l-dvb
>> searching for changes
>> no changes found
>> The command "hg diff" shows no differences. It seems that both
>> directories contains the same source code like the
>> repository on http://linuxtv.org/hg/v4l-dvb. If I run a normal diff
>> between both directories, I get an output of 486
>> lines. 11 files have differences. It seems, that 'hg pull -u' doesn't
>> work properly. What do I do wrong?
> Have you tried doing a hg commit after having modifications in your
> local tree ?
No, I don't use the hg commit command. I think it makes no sense,
because I've read only access. The differences between the two
directories have nothing to do withe my reverted changes in one of the

- Hartmut

More information about the linux-dvb mailing list