[linux-dvb] TT-1500 / TDA10046

Nicholas Fearnley nfearnley at dmpip.tv
Wed Feb 21 00:37:06 CET 2007

I have had real problems getting the TT-1500 (DVB-T) working.

I have been using dvbtune for some diagnostics.

The following should yield BBC Multiplex on my local transmitter

dvbtune -c 0 -qam 16 -gi 32 -cr 3_4 -bw 8 -tm 2 -f 722000

It does not, I tried adding 166Khz (722166) but no luck.  So I tried  
just working my way through some frequencies.  I can get the  
FE_STATUS to report FE_HAS_SIGNAL on some frequencies.  I even get  
FE_HAS_CARRIER on occasion but never any more than that.

Does this mean the tuner is getting *something*.  It's not random for  
sure, I always get this result on the few frequencies I have tried.   
I am using  I know the signal (antenna) to be OK as I get  
no issues with a CX based DVB-T module, on any frequency I pick.   
This has to be a driver or settings issue.  I compile the relevant  
modules into the kernel, I get valid firmware loads in dmesg (version  

I can insert relevant debugging code if needed - if anyone has any  
ideas what might help.  I can send a TT unit out if anyone needs one  
to test with.


More information about the linux-dvb mailing list