[linux-dvb] saa7134

Hartmut Hackmann hartmut.hackmann at t-online.de
Fri Feb 23 23:55:56 CET 2007


Vaughan Famularo schrieb:
> H all
> I have tried to get my Compro DVB300T working in Linux for the past two
> weeks but I have finally conceded defeat!
> I was told to install the latest drivers into my 2.6-16 kernel, which I
> did with no luck.
> So then I installed the latest version of PClinuxOS which has the latest
> kernel with the relative drivers installed and the modules compiled into
> the kernel.
Hm, did you really mean this?
1) You should not try to merge code from linuxtv.org into the kernel source
   tree. You should compile it separately (but you need installed kernel sources
   and you need to have v4l2 enabled in the kernel).
2) You should compile the video and dvb code as modules. Don't compile them into
   the kernel.

> Now, on startup I can get analogue tv working in Xawtv IF I DON'T load
> the modules saa7134 or saa7134-dvb. After I load the modules I cannot
> get any program, Tvtime, xawtv, kaffeine or mplayer to find any channels.
Hm, the card can't work at all without the saa7134 driver...
Unless you really compiled the stuff into the kernel -> see above.

> My hope is to be able to get Digital video stations showing in Mythtv.
> BUT I hav'nt installed Mythtv yet as I don't want to commit myself to
> that weekend of work until I can be assured that I can get the stations
> working.
> Can someone help me please???? I am not a newbie, but I am far from an
> expert either. I am happy to install any program or do anything that you
> ask of me.
The card should work with recent kernels, i have a very similar one.
But besides the module issue, there are 2 pitfalls:
- For a technical reason, you must not load the tuner module before
  the saa7134 module.
- There was a bug in some versions that made dvb-t support fail. This
  is fixed in the current repository (and also in 2.6.20)

After you corrected these things and it still doesn't work, you need
to provide more information. Please send us the kernel log messages
caused by the "modprobe"


More information about the linux-dvb mailing list