[linux-dvb] HVR3000 Analogue tuner problems

Robert Longbottom RobertCL at iname.com
Tue Jan 9 18:33:51 CET 2007

Simon Bazley wrote:
> Robert,
> 	What commands have you had success with, to get sound working?  If I use arecord and aplay I get a 2 second lag, so the lip sync is out.  If I use
> sox I get pitch shifting and other resampling problems (the frame was in the right place but obviously the out wasn't getting the same amount of data
> as the in).

Something along the lines of (from memory)

	arecord -D hw:1,0 -f S16_LE -c 2 -r 48000 | aplay

I did originally have the problem that the audio was initially in sync, 
but very quickly drifted out of sync with the picture I was watching in 
xawtv.  But last time I tried it this was fine.

> 	Simon
> P.S. I'm in a position now to try a few things rebooting this machine repeatedly.  Where did you find out about cx88xx module options?  I'll try a
> number of things and see what success I get.

I simply used 'modinfo cx88xx' and guessed at some values.

I've also seen suggested that 'options tuner port2=-1' might help, but 
it never seemed to do me any good, and I can't begin to guess at what it 
  might do so I don't have that set at the minute.

> Robert Longbottom wrote:
>> On Sun, January 7, 2007 10:09 pm, Simon Bazley wrote:
>>> Robert Longbottom wrote:
>>>  > The key for me when rmmoding and modprobing is getting the following
>>>> line to appear in dmesg :
>>>>     tda9887 2-0043: tda988[5/6/7] found @ 0x43 (tuner)
>>>> Until I've got that, the tuner doesn't work properly.  I also have the
>>>> following in my modules.conf:
>>>>     options cx88xx i2c_scan=1
>>>> I'm not sure if it makes any difference of not.  But it might be worth a
>>>> try.
>>> Great, I tried that and eventually it worked.
>>> I I created a file (cx88) in /etc/modules.d with the options line in it,
>>> rmmoded tuner followed by modprobing it back and nothing,
>>> So I unloaded a load of modules (trying to work back to unload cx88xx, but
>>> not getting that far) and ran this:-
>>> rmmod tuner; sleep 5; modprobe tuner; dmesg |grep tda
>>> And magically after 5 seconds:-
>>> [17201706.416000] tda9887 2-0043: tda988[5/6/7] found @ 0x43 (tuner)
>> Interesting.  I'll have to try that in my startup script.  I have that
>> rmmod && modprobe twice in there, but it still doesn't always work.
>>> Then I managed to run scantv and pick up everything I expected to, great.
>>> Looking back I had unloaded tuner cx88xx cx8802 and cx8800
>> That rings a bell.  I think I usually need to unload cx88_alsa and
>> cx88_dvb as well.
>>> I'll reboot in a bit and try again without your modules file and see if
>>> that in important or not.
>> You'll have to report back the results.  I know the HVR3000 developer
>> Steve Toth follows this list.  I'm sure I've tried in the past messing
>> around with module options, but it still seemed random to me whether it
>> detected the tuner or not.
>> Robert.
>> _______________________________________________
>> linux-dvb mailing list
>> linux-dvb at linuxtv.org
>> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb

More information about the linux-dvb mailing list