[linux-dvb] Re: qt1010 / m9206 / gl861 / au6610 testers wanted

Jan Jan.Nijs at scarlet.be
Wed Jan 24 23:22:56 CET 2007

> Jan,
> Thank you for testing.  It is most likely that you do nto have the qt1010 module
> built.  In the last version that you've used successfully, the qt1010 code was
> compiled inline within the dvb-usb drivers.  Antti has since created a proper
> dvb tuner module, which attached to the driver via the dvb_attach() method.
> Please do "make distclean" before attempting to compile the repository again.
> Cheers,
> Michael Krufky
Nope, that's not it.
I downloaded two clean copies of the repository: make; make install;
reboot machine and modprobe dvb_usb_gl861.

DVB: registering new adapter (MSI Mega Sky 55801 DVB-T USB2.0).
DVB: registering frontend 0 (Zarlink ZL10353 DVB-T)...
Quantek QT1010 successfully identified.
dvb-usb: MSI Mega Sky 55801 DVB-T USB2.0 successfully initialized and
usbcore: registered new interface driver dvb_usb_gl861
zl10353: write to reg 62 failed (err = 0)!
zl10353: write to reg 62 failed (err = 0)!

I noticed a few write to reg 62 failures. Not all the time, but when I
leave "dvbtune -f 482000000" running for a while, they start appearing.
This is the "gate" register, so could be one of the reasons why I don't
get a lock. (and none of the other signal indicators like viterbi, ...)
I tried several other frequencies above and below. I know that in the
past my patch only differed from mercurial in a few zl10353 registers.
No direct impact on the qt1010 tuning frequency as far as I can tell.

I will just need more time to perform a decent analysis of the settings
that differ on my side and in mercurial.
I will first test the "zl10353_single_write(fe, 0x5a, 0x0c);" line I
needed to add in the past.
Adding this line worked for me, but this caused problems for comabug.


More information about the linux-dvb mailing list