[linux-dvb] saa7146_i2c_writeout: timed out waiting for end of xfer

Manfred Petz pm at deuromedia.at
Tue Jul 10 11:24:42 CEST 2007

On Tue, 2007-07-10 at 00:16 +0200, Oliver Endriss wrote:
> > i'm experiencing a similar problem. using with latest hg dvb
> > driver (knc-1 dvb-s) everything works. though, from at least
> > on, with the same kernel config and same hardware (same dvb drivers), i
> > get those i2c timeouts and, when doing 'modprobe budget-av', not all
> > cards get deteced. 
> > 
> >   kernel: KNC1-5: Could not read MAC from KNC1 card
> >   kernel: saa7146_i2c_writeout: timed out waiting for end of xfer
> >   last message repeated 7 times
> >   budget-av: A frontend driver was not found for device 1131/7146 subsystem 1894/0016
> > 
> > since i'm using the same dvb driver, that problem seems to be triggered
> > somewhere else.
> Could you please try the attached patch (saa7146_i2c_retry.diff)?
> If it does not help, please try the second patch
> (budget-av_slowi2c.diff).
> Any improvements?

hi oliver,

actually, both patches help. no more timeouts, and the frontend drivers
get loaded correctly (tried each patch separately). tried with latest hg
& 2.6.22.

though, what's weird: now i also discover those "Disabling IRQ #xx,
nobody cared" messages, which some people experienced as well. well,
it's no dvb issue. i tried many combinations of kernel parameters
with/without acpi/apic, ... disabled almost everything in BIOS, etc. :-/
but the last working version for me is still


More information about the linux-dvb mailing list