[linux-dvb] Hauppauge WinTV Nova-S-Plus - multiple read accesses impossible

Fabian Förg fabian.foerg at gmx.de
Sat Jul 28 02:52:51 CEST 2007

Simon Santoro wrote:
> On Friday 27 July 2007 18:09:01 Fabian Förg wrote:
>> Fabian Förg wrote:
>>> Hello,
>>> in newer kernel releases multiple read accesses on the Hauppauge WinTV
>>> Nova-S-Plus are impossible.
>>> Thus, the command line femon is for example unable to open the DVB
>>> device when VDR is running:
>>> $ fuser -v /dev/dvb/adapter0/frontend0
>>>                    USER        PID ACCESS COMMAND
>>> /dev/dvb/adapter0/frontend0:
>>>                    myuser     5073 F.... vdr
>>> $ femon
>>> using '/dev/dvb/adapter0/frontend0'
>>> opening frontend failed: Device or resource busy
>>> I encounterd this issue with kernel and the current Ubuntu
>>> feisty kernel (2.6.20.x).
>>> Older kernels allowed multiple accesses. However, I can't test which
>>> ones, because I replaced
>>> my system board some time ago, and older kernels don't contain the
>>> necessary drivers for the board.
>>> Greets,
>>> Fabian
>> Today I tested it with the newest v4l-sources - also no multiple read
>> accesses possible.
>> Any suggestions?
> I don't know if this ever worked, but just to help you a bit, I tested it on 
> my 2.6.20 kernel, and I get the same.
> root at black:/home/mythtv# fuser /dev/dvb/adapter0/frontend0
> /dev/dvb/adapter0/frontend0:  5266
> root at black:/home/mythtv# femon
> using '/dev/dvb/adapter0/frontend0'
> opening frontend failed: Device or resource busy
> root at black:/home/mythtv#
It worked some time ago. But a kernel switch, vdr-femon stopped working 
in VDR.
First, I thought that this was a problem with vdr-femon.
So I tried to debug it and with the help of the vdr-femon maintainer I 
found out that vdr-femon was
unable to open the DVB device (error message: "16: Device or resource 
The maintainer of vdr-femon thought that this was an issue with the DVB 
driver of my card.
Steven Toth of Hauppauge replied: "The driver does not deal with open() 
calls, that's the responsibility of the dvb layer, or the cx88 driver. 
The problem is likely in those parts."

More information about the linux-dvb mailing list