[linux-dvb] af9005/mt2060 module unload failure

Luca Olivetti luca at ventoso.org
Thu Jun 14 21:11:00 CEST 2007

En/na Olaf Titz ha escrit:
>> ... You should not have to do the symbol_put inside af9005-fe.c
>>   If you remove that code, does it fix the issue?
> If I remove it, unloading the modules works, but on re-loading I get
> the same error:
> __tune_to_transponder:1507: ERROR: FE_READ_STATUS failed: 19 No such device
> when I try to invoke "scan" after re-loading the modules. Looks like
> the connection between demux and frontend driver gets lost (btw.
> "modprobe -r dvb_usb_af9005" now does not unload mt2060 too, is that a
> hint?)

Yes, there's still a reference to it so it's impossible to unload (I think)

> When I physically remove and re-insert the USB device it works.
> So this fixes the module count issue,

are you sure that the usage count of the mt2060 has gone to 0?

> but reloading fails nonetheless.
> Either there is an issue with module loading which udev magically gets
> right, or the driver doesn't like a "warm" device at all [btw. "warm"

Yes, I saw it too, but I thought I fixed it (in fact, I couldn't talk to 
the device at all, I was getting bulk timeouts all the time).

> is appropriate, the device does get really hot; is it possible to
> disable it by software when unused so it does not draw that much power?]

I don't think so, anyway I cannot test it anymore: my stick has died 
(or, at least, it doesn't tune anything).


More information about the linux-dvb mailing list