[linux-dvb] af9005/mt2060 module unload failure

Olaf Titz olaf at bigred.inka.de
Fri Jun 15 12:47:21 CEST 2007

Hash: SHA1

> Attached.
> I can test it up to the point where it correctly attaches the mt2060,
> but then I don't know if it tunes correctly since my stick doesn't work
> (though it should, since it does the same as before, only without the
> extra "tuner" pointer). Olaf, could you give it a try?

Works so far.

> I also tried (again) to unload and reload the module and, while at first
> it seems to recognize and initialize, after a (short) while it gives
> bulk transfer errors, so in case the module is unloaded the stick must
> be reconnected.

The same for me.

If I unload only af9005 everything works fine. These errors seem to
happen only after unloading mt2060.

Another observation:
When I run tzap in one window and dvbsnoop in another, then stop the
tzap, I have this:
# lsmod | head
Module                  Size  Used by
mt2060                  6148  1
dvb_usb_af9005         26004  0
# fuser /dev/dvb/adapter0/*
/dev/dvb/adapter0/demux0: 14596

I can even unload the af9005 module, but modprobe waits until I stop the
tzap process.

After stopping tzap I get
# lsmod | head
Module                  Size  Used by
mt2060                  6148  1
dvb_usb_af9005         26004  4294967295
(not sure if this happens all the time though).

(Btw. once tuned, the actual hardware seems to not care about the tuner
module at all, I can stop tzap, lose lock due to disconnected antenna,
etc. and the demuxer doesn't stop streaming. Is this intentional,
hardware limitation, or what?)

Version: GnuPG v1.4.3 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the linux-dvb mailing list