[linux-dvb] tda10086 diseqc support? (Lifeview FlyDVB Trio)

Hartmut Hackmann hartmut.hackmann at t-online.de
Mon Jun 18 01:07:24 CEST 2007


Zenon Mousmoulas schrieb:
> Hi,
> I have a Lifeview FlyDVB Trio PCI card.
> 06:01.0 Multimedia controller: Philips Semiconductors SAA7133/SAA7135 Video Broadcast Decoder (rev d1)
>         Subsystem: Animation Technologies Inc. LifeView FlyDVB Trio
>         Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B-
>         Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
>         Latency: 32 (21000ns min, 8000ns max)
>         Interrupt: pin A routed to IRQ 74
>         Region 0: Memory at fc402000 (32-bit, non-prefetchable) [size=2K]
>         Capabilities: [40] Power Management version 2
>                 Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
>                 Status: D0 PME-Enable- DSel=0 DScale=1 PME-
> I am running Debian etch (2.6.18-4-686). I have obtained v4l-dvb through Mercurial (tag 5697:015313b16eab ? dated 20070522), replacing /lib/modules/2.6.18-4-686/kernel/drivers/media. I also got rid of the dvb-utils package and installed dvb-apps through Mercurial.
> I have loaded saa7134-dvb with option use_frontend=1.
> I am trying to tune to a DiSeqC 1.0 switch, which takes input from 4 LNBs. The dish/lnb/switch reception works well, I have tested reception of all 4 satellites with another set top box.
> The problem is I can not get diseqc to work. I have tried scan -s X but it always seems to tune to transponders on satellite in position 1 (Hotbird 13E), no matter what. I have also tried tuning directly with other tools (such as dvbtune and VLC) but the result is always the same. I can tune to transponders on Hotbird, no matter what setting I use for diseqc.
> I am wondering if this card and this frontend supports diseqc at all? I have found some older posts in this list which suggest that tda10086 should now work with diseqc, but I am not so sure after all. Perhaps I am doing something wrong, as I am rather new to linux-dvb. Any ideas would be appreciated.
> Thanks,
> Z.
> PS: I have also tested the terrestrial frontend, and it works fine.

Yes, there is a known problem and a proposed patch. I need to cross check whether
this breaks other drivers.

Best regards

More information about the linux-dvb mailing list