[linux-dvb] Bad TS from dvb-t recording?

Torbjörn Lundquist torbjorn.lundquist at googlemail.com
Thu Mar 8 17:03:40 CET 2007


I'm trying to make a recording from my dvb-t card (Avermedia). I do like

> tzap -r -c channels.conf -t 5 -o test.ts SVT24

using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
reading channels from file 'channels.conf'
tuning to 522000000 Hz
video pid 0x04e1, audio pid 0x04e0
status 00 | signal 58cf | snr 0000 | ber 00000000 | unc 00000000 |
copied 1708168 bytes (333 Kbytes/sec)
status 1f | signal f1cf | snr c0c0 | ber 00000000 | unc 00000000 |

But then I cannot view the file in VLC for instance. If I run dvbsnoop on it
I receive some errors, for instance:

MPEG-DescriptorTag: 63 (0x3f)  [= ITU-T.Rec.H.222.0|ISO/IEC13818-1 Reserved]
            Descriptor_length: 199 (0xc7)
              ----> ERROR: unimplemented descriptor (mpeg context), Report!

I live in Sweden and receive the signal from the Motala-tranciever.

What am I doing wrong? Or can I use some other program for recording (I
tried mencoder without success)?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20070308/59704f98/attachment-0001.htm

More information about the linux-dvb mailing list