[linux-dvb] Bad TS from dvb-t recording?

Andrea Venturi a.venturi at cineca.it
Thu Mar 8 17:24:22 CET 2007

Torbjörn Lundquist wrote:
> Hi,
> I'm trying to make a recording from my dvb-t card (Avermedia). I do like
> this:
>> tzap -r -c channels.conf -t 5 -o test.ts SVT24
> using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
> reading channels from file 'channels.conf'
> tuning to 522000000 Hz
> video pid 0x04e1, audio pid 0x04e0
> status 00 | signal 58cf | snr 0000 | ber 00000000 | unc 00000000 |
> copied 1708168 bytes (333 Kbytes/sec)
> status 1f | signal f1cf | snr c0c0 | ber 00000000 | unc 00000000 |
> But then I cannot view the file in VLC for instance. If I run dvbsnoop
> on it I receive some errors, for instance:
> MPEG-DescriptorTag: 63 (0x3f)  [= ITU-T.Rec.H.222.0|ISO/IEC13818-1 Reserved]
>             Descriptor_length: 199 (0xc7)
>               ----> ERROR: unimplemented descriptor (mpeg context), Report!
> I live in Sweden and receive the signal from the Motala-tranciever.
> What am I doing wrong? Or can I use some other program for recording (I
> tried mencoder without success)?

i just try a guess. i don't use tzap.

maybe tzap doesn't dump the relevant tables (PAT PMT) so VLC can't
reconstruct the service.
i see indeed only video and audio pids in the log.

can you try to dump the complete transport stream using maybe dvbstream

you can try with the one available in your linux distro, but if it does
not work well you can try from the cvs source:


get the code straight from the cvs because it's newer then the (old)

when you have a binary, give this command:

  dvbstream -f 522000 -o -tm 8 8192 > /tmp/test.ts

then after some time, break the application with CTRL-C.

beware, this should be a 24Mbps stream, so it will waste some space in
the disk!

then feed it with vlc

  vlc /tmp/test.ts

and if it works you can switch on every service of the mux with the menu

hope it helps.


andrea venturi

More information about the linux-dvb mailing list