[linux-dvb] Lifeview Hybric PCI problems mainly with dvb-t

scoop_yo at freemail.gr scoop_yo at freemail.gr
Thu Mar 22 19:34:48 CET 2007

   Yesterday I bought Lifeview Hybrid PCI(Analog TV, DVB-T and radio FM).
The problem with this card is that I cannot tune to dvb-t channels.
I run and used latest mercurial snapshot for v4l.

$lspci -vvv :

05:07.0 Multimedia controller: Philips Semiconductors SAA7133/SAA7135 Video Broadcast Decoder (rev d1)
Subsystem: Animation Technologies Inc. Unknown device 3306
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 32 (21000ns min, 8000ns max)
Interrupt: pin A routed to IRQ 20
Region 0: Memory at d0005000 (32-bit, non-prefetchable) [size=2K]
Capabilities: [40] Power Management version 2
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=1 PME-

dmesg output:
 The module seems to find the firmware somewhere but it isn't anywhere
 in my system as a single file (dvb-fe-tda10046.fw).

 Later I pulled the firmware using the get_dvb_firmware perl script but that 
 didn't make dvb-t to work so I deleted it.
 I tried both tda10046lifeview and tda10046 firmwares.
 I don't run hotplug though..

Linux video capture interface: v2.00
saa7130/34: v4l2 driver version 0.2.14 loaded
ACPI: PCI Interrupt Link [APC2] enabled at IRQ 17
ACPI: PCI Interrupt 0000:05:07.0[A] -> Link [APC2] -> GSI 17 (level, low) -> IRQ 20
saa7133[0]: found at 0000:05:07.0, rev: 209, irq: 20, latency: 32, mmio: 0xd0005000
saa7133[0]: subsystem: 5168:3306, board: LifeView FlyDVB-T Hybrid Cardbus [card=94,autodetected]
saa7133[0]: board init: gpio is 210000
PM: Adding info for No Bus:i2c-2
PM: Adding info for No Bus:i2c-2
saa7133[0]: i2c eeprom 00: 68 51 06 33 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7133[0]: i2c eeprom 10: 00 00 62 08 ff 20 ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 20: 01 40 01 03 03 01 01 03 08 ff 01 16 ff ff ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 40: ff 21 00 c2 96 10 05 01 01 16 32 15 ff ff ff ff
saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
tuner 2-004b: chip found @ 0x96 (saa7133[0])
PM: Adding info for i2c:2-004b
tuner 2-004b: setting tuner address to 61
tuner 2-004b: type set to tda8290+75a
tuner 2-004b: setting tuner address to 61
tuner 2-004b: type set to tda8290+75a
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0
saa7133[0]: registered device radio0
ACPI: PCI Interrupt Link [APC3] enabled at IRQ 18
ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [APC3] -> GSI 18 (level, low) -> IRQ 21
PCI: Setting latency timer of device 0000:01:00.0 to 64
DVB: registering new adapter (saa7133[0]).
DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
tda1004x: setting up plls for 48MHz sampling clock
tda1004x: found firmware revision 29 -- ok

(Everything is detected from udev I guess, except for the sound)

tda827x                 6152  1
saa7134_dvb            16024  0
dvb_pll                11528  1 saa7134_dvb
video_buf_dvb           4488  1 saa7134_dvb
dvb_core               72396  1 video_buf_dvb
tda1004x               14984  2 saa7134_dvb
tuner                  64760  0
saa7134               120012  1 saa7134_dvb
video_buf              19720  3 saa7134_dvb,video_buf_dvb,saa7134
compat_ioctl32          1024  1 saa7134
ir_kbd_i2c              6808  1 saa7134
ir_common              29708  2 saa7134,ir_kbd_i2c
videodev               26368  1 saa7134
v4l2_common            15232  3 tuner,saa7134,videodev
i2c_nforce2             4672  0
v4l1_compat            12552  2 saa7134,videodev

#modprobe saa7134-alsa (dmesg output):

saa7134 ALSA driver for DMA sound loaded
saa7133[0]/alsa: saa7133[0] at 0xd0005000 irq 20 registered as card -1
PM: Adding info for No Bus:card1
PM: Adding info for No Bus:pcmC1D0c
PM: Adding info for No Bus:dsp1
PM: Adding info for No Bus:audio1
PM: Adding info for No Bus:controlC1
PM: Adding info for No Bus:mixer1

I can watch analog tv with no sound.I did some tests with sox
with both saa7137-alsa and saa7137-oss but no luck here.
I haven't tried the radio yet.
I see nothing for the remote at /proc/bus/input/devices.
But the feature that I desperately want to use is dvb-t because I kinda
bought it more for it to do some recording of next week's shows starting
on Sunday :) .

Using scan with latest (mercurial snapshot) dvb-apps I get the following:
Settings of gr-Athens file are correct.
(Didn't have any luck with kaffeine either.)

$./scan ./gr-Athens
scanning ./gr-Athens
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
initial transponder 690000000 0 3 9 1 1 1 0
WARNING: >>> tuning failed!!!
WARNING: >>> tuning failed!!!
ERROR: initial tuning failed
dumping lists (0 services)

(After the scan dvbsnoop reports that inversion is off.)
I assumed it was a singal strength problem so I installed Windows and
the card worked ok with dvb-t.
On the card there is a SAA1733 chip but on the wiki I didn't find any other card
with that chip so that I cound try parsing it as a parameter and check dvb-t usage.

Any ideas primarely on how to get dvb-t to work ?

PS:If it is to look at the driver code, should I be looking at
TDA10046 , SAA1734 or both ?

More information about the linux-dvb mailing list