[linux-dvb] Problems with Terratec Cinergy 1200 DVB-T (tda10046_attach())

Oliver Haag oliver at haag.eu.org
Sat Nov 10 17:59:28 CET 2007


I've bought the Terratec Cinergy 1200 DVB-T and have problems to get it 

I'm using Kubuntu Gutsy (amd64) with the vanilla kernel (The 
official kernel in the repos is very very buggy, so I don't want to try 
it out there). Tried adding the modules in menuconfig and building them 
as described here 
too. I always get the same error in dmesg:

saa7146: register extension 'budget_av'.
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 18
ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [LNKA] -> GSI 18 (level, 
low) -> IRQ
saa7146: found saa7146 @ mem ffffc20000aaec00 (revision 1, irq 18) 
saa7146 (0): dma buffer size 192512
DVB: registering new adapter (Terratec Cinergy 1200 DVB-T)
adapter failed MAC signature check
encoded MAC from EEPROM was 
bttv: driver version 0.9.17 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
nvidia: module license 'NVIDIA' taints kernel.
KNC1-0: MAC addr = 00:0a:ac:01:e7:02
DVB: Unable to find symbol tda10046_attach()
budget-av: A frontend driver was not found for device 1131/7146 
subsystem 153b/1157
budget-av: ci interface initialised.

It looks like the tda1004x-module is missing, but it isn't. It's also 
Module                  Size  Used by
tda1004x               16900  0
lp                     11912  0
budget_av              21120  0
saa7146_vv             46912  1 budget_av
videobuf_dma_sg        13444  2 bttv,saa7146_vv
videobuf_core          17028  3 bttv,saa7146_vv,videobuf_dma_sg
budget_core            11524  1 budget_av
dvb_core               76116  2 budget_av,budget_core
videodev               27456  2 bttv,saa7146_vv
v4l2_common            19968  4 bttv,compat_ioctl32,saa7146_vv,videodev
v4l1_compat            13316  3 bttv,saa7146_vv,videodev
saa7146                17480  3 budget_av,saa7146_vv,budget_core
ttpci_eeprom            4352  1 budget_core

The frontend device-node is missing, everything else is there:
$ ls /dev/dvb/adapter0/
ca0  demux0  dvr0  net0

Also installed WinXP to try it out there and it's working fine, so it's 
no hardware-problem.

Is this a bug (probably only on amd64 kernels) or am I just too stupid 
and did forget something?

Thanks in advance,
Oliver Haag

More information about the linux-dvb mailing list