[linux-dvb] USB issues

Philipp Wehrheim flipstar at gmx.net
Thu Nov 29 09:50:52 CET 2007

Am Donnerstag, den 29.11.2007, 01:49 +0000 schrieb Yousef Lamlum:
> > Hey Yousef,
> > 
> > Yousef Lamlum wrote:
> >> Hi,
> >> 
> >> Perhaps this is the wrong place to ask but I've been having a USB
> >> related issue with my Artec T14BR (Ultima Electronics). It's a USB 2.0
> >> device and it's plugged in to a PCI USB 2.0 card (with NEC chipset).
> >> The problem is this: When booting from cold (powered off), the Ubuntu
> >> boots fine but does not recognise the T14BR. dmesg tells me "usb 3-3:
> >> device descriptor read/64, error -62".  Subsequent reboots do not make
> >> the device work either.
> >> 
> >> However, if I physically unplug and replug in the device it is picked
> >> up, the driver loads and it works instantly, and remains working with
> >> each reboot until the computer is powered down.
> >> 
> >> I've researched the problem, and tried a variety of suggestions (tried
> >> other USB ports on the card, passing boot options to the kernel, trying
> >> different cables) all with no difference.
> >> 
> >> Given that a fair few of you use USB 2.0 devices, has anyone come across
> >> this problem before, and if so, does anyone have a solution?
> > 
> > This is because the firmware is not part of the initrd/initramfs
> > used by ubuntu.
> > You'll have to create on with the needed files.
> > 
> > --
> > flip
> Thanks for this. I've just been looking into how I can include the
> firmware into the initramfs image used by Ubuntu 7.10 and have drawn a
> blank.
> Also this solution seems a little odd to me. Admittedly my Linux
> experience is limited, but why is the firmware needed so early on in the
> booting process? Isn't the loading of firmware onto the device a process
> that occurs when the module loads?

Are you unsing the dvb-modules that ship with ubuntu?

I guess what they do, when building the initramfs, is simply copy
_all_ modules into it. During the boot (initramfs)-init gets the
hotplug events and loads the module. But the module can not find the
firmware ...

You may want to read the early-userspace ReadMe:


You could remove the module from the initramfs.


More information about the linux-dvb mailing list