[linux-dvb] USB issues

Yousef Lamlum yousef.lists at youseflamlum.com
Fri Nov 30 00:00:05 CET 2007

> On Thu, November 29, 2007 1:49 am, Yousef Lamlum wrote:
>>> Hey Yousef,
>>> Yousef Lamlum wrote:
>>>> Hi,
>>>> Perhaps this is the wrong place to ask but I've been having a USB
>>>> related issue with my Artec T14BR (Ultima Electronics). It's a USB 2.0
>>>> device and it's plugged in to a PCI USB 2.0 card (with NEC chipset).
>>>> The problem is this: When booting from cold (powered off), the Ubuntu
>>>> boots fine but does not recognise the T14BR. dmesg tells me "usb 3-3:
>>>> device descriptor read/64, error -62".  Subsequent reboots do not make
>>>> the device work either.
>>>> However, if I physically unplug and replug in the device it is picked
>>>> up, the driver loads and it works instantly, and remains working with
>>>> each reboot until the computer is powered down.
>>>> I've researched the problem, and tried a variety of suggestions (tried
>>>> other USB ports on the card, passing boot options to the kernel, trying
>>>> different cables) all with no difference.
>>>> Given that a fair few of you use USB 2.0 devices, has anyone come
>>>> across
>>>> this problem before, and if so, does anyone have a solution?
>>> This is because the firmware is not part of the initrd/initramfs
>>> used by ubuntu.
>>> You'll have to create on with the needed files.
>>> --
>>> flip
>> Thanks for this. I've just been looking into how I can include the
>> firmware into the initramfs image used by Ubuntu 7.10 and have drawn a
>> blank.
>> Also this solution seems a little odd to me. Admittedly my Linux
>> experience is limited, but why is the firmware needed so early on in the
>> booting process? Isn't the loading of firmware onto the device a process
>> that occurs when the module loads?
>> If this is a elementary question please excuse my lack of knowledge!
> I'd also suggest you look at hotplug / coldplug services.  I'm not sure
> how Ubuntu does this, but I think that coldplug is responsible for
> initializing devices already connected when the computer boots, and
> hotplug is responsible for devices that get plugged / unplugged while the
> computer is running.  Maybe coldplug isn't running on startup on your PC ?
> Robert.

Thanks for all the pointers.

Ok, so managed to get the dvb-usb-dib0700-1.10.fw firmware file included
in the initramfs image (By referring to initramfs-tools manpage!) but
unfortunately the problem remained. I then also included the relevant
modules for the device and still no luck.

With regards to coldplug, apparently Ubuntu 7.10 no longer uses it as
udev has it's own coldplug functionality.

So, I'm a bit stumped by this problem. It's really only an annoyance
that I have to manually unplug and plug in my DVB stick everytime I boot
my system, but I'd still very much like to find a solution. Any other
ideas anyone?

Thanks again for the help,


More information about the linux-dvb mailing list