[linux-dvb] USB issues

Yousef Lamlum yousef.lists at youseflamlum.com
Fri Nov 30 01:01:26 CET 2007

flipstar at gmx.net wrote:
> Yousef Lamlum schrieb:
>>> On Thu, November 29, 2007 1:49 am, Yousef Lamlum wrote:
>>>>> Hey Yousef,
>>>>> Yousef Lamlum wrote:
>>>>>> Hi,
>>>>>> Perhaps this is the wrong place to ask but I've been having a USB
>>>>>> related issue with my Artec T14BR (Ultima Electronics). It's a USB 2.0
>>>>>> device and it's plugged in to a PCI USB 2.0 card (with NEC chipset).
>>>>>> The problem is this: When booting from cold (powered off), the Ubuntu
>>>>>> boots fine but does not recognise the T14BR. dmesg tells me "usb 3-3:
>>>>>> device descriptor read/64, error -62".  Subsequent reboots do not make
>>>>>> the device work either.
>>>>>> However, if I physically unplug and replug in the device it is picked
>>>>>> up, the driver loads and it works instantly, and remains working with
>>>>>> each reboot until the computer is powered down.
>>>>>> I've researched the problem, and tried a variety of suggestions (tried
>>>>>> other USB ports on the card, passing boot options to the kernel, trying
>>>>>> different cables) all with no difference.
>>>>>> Given that a fair few of you use USB 2.0 devices, has anyone come
>>>>>> across
>>>>>> this problem before, and if so, does anyone have a solution?
>>>>> This is because the firmware is not part of the initrd/initramfs
>>>>> used by ubuntu.
>>>>> You'll have to create on with the needed files.
>>>>> --
>>>>> flip
>>>> Thanks for this. I've just been looking into how I can include the
>>>> firmware into the initramfs image used by Ubuntu 7.10 and have drawn a
>>>> blank.
>>>> Also this solution seems a little odd to me. Admittedly my Linux
>>>> experience is limited, but why is the firmware needed so early on in the
>>>> booting process? Isn't the loading of firmware onto the device a process
>>>> that occurs when the module loads?
>>>> If this is a elementary question please excuse my lack of knowledge!
>>> I'd also suggest you look at hotplug / coldplug services.  I'm not sure
>>> how Ubuntu does this, but I think that coldplug is responsible for
>>> initializing devices already connected when the computer boots, and
>>> hotplug is responsible for devices that get plugged / unplugged while the
>>> computer is running.  Maybe coldplug isn't running on startup on your PC ?
>>> Robert.
>> Thanks for all the pointers.
>> Ok, so managed to get the dvb-usb-dib0700-1.10.fw firmware file included
>> in the initramfs image (By referring to initramfs-tools manpage!) but
>> unfortunately the problem remained. I then also included the relevant
>> modules for the device and still no luck.
>> With regards to coldplug, apparently Ubuntu 7.10 no longer uses it as
>> udev has it's own coldplug functionality.
>> So, I'm a bit stumped by this problem. It's really only an annoyance
>> that I have to manually unplug and plug in my DVB stick everytime I boot
>> my system, but I'd still very much like to find a solution. Any other
>> ideas anyone?
> There are two ways you can do:
> - the simple, write a script that once the system is up and running 	
> 	unloads and reloads the module and live is good.
> - the hard way, understand why the firmware is not loaded
> 	if the Ubuntu initramfs uses busybox and thus mdev
> 	it is possible that it is compiled without firmware-load
> 	support. But this are only guesses so a Ubuntu ML would be the
> 	right place for this ...
> Anyway I always responce to your mail and CC the linuxtv ML but the mail
> send to you is rejected. Not sure if you expect it to work that way ...
> --
> flip

Thanks for the response flip.

I already tried loading (and unloading, and loading, and unloading,
etc...) the dvb-usb-dib0700 module once the system was up and running
and it did nothing. Same with the ehci_hid and ohci_hid modules.

I still think the main issue here is not a firmware or module one, but
with the system being unable to assign an address to the device. Looking
again at the dmesg output I including in my original post I'm also
wondering why the device is trying to be used as a "full speed" i.e USB
1.0 device using ohci rather than a "high speed" i.e USB 2.0 device
using ehci.  Is there a way to force the use of ehci on a particular device?

[   26.653192] usb 3-3: new full speed USB device using ohci_hcd and
address 2
[   26.833128] usb 3-3: device descriptor read/64, error -62
[   27.117050] usb 3-3: device descriptor read/64, error -62
[   27.396942] usb 3-3: new full speed USB device using ohci_hcd and
address 3
[   27.576888] usb 3-3: device descriptor read/64, error -62
[   27.860793] usb 3-3: device descriptor read/64, error -62
[   28.140687] usb 3-3: new full speed USB device using ohci_hcd and
address 4
[   28.548548] usb 3-3: device not accepting address 4, error -62
[   28.724498] usb 3-3: new full speed USB device using ohci_hcd and
address 5
[   29.132360] usb 3-3: device not accepting address 5, error -62



More information about the linux-dvb mailing list