[linux-dvb] Strage SkyStar HD modprobe

Artem Makhutov artem at makhutov.org
Tue Oct 16 21:12:21 CEST 2007


On Mon, Oct 15, 2007 at 11:22:37PM +0200, Artem Makhutov wrote:
> Hi,
> On Tue, Oct 16, 2007 at 01:18:12AM +0400, Manu Abraham wrote:
> [...]
> > A question here. Is your PCI ID still changing randomly ?
> No, it seems to be stable now.
> $lspci
> 02:05.0 0480: 1131:7146 (rev 01)
>         Subsystem: 13c2:1019
>         Flags: bus master, medium devsel, latency 64, IRQ 17
>         Memory at e8101000 (32-bit, non-prefetchable) [size=512]

Has some one an idea what I could try to get the module loaded?

I have still the same old problem:

saa7146: register extension 'budget_ci dvb'.
ACPI: PCI Interrupt 0000:02:05.0[A] -> GSI 17 (level, low) -> IRQ 17
saa7146: found saa7146 @ mem e0822000 (revision 1, irq 17) (0x13c2,0x1019).
saa7146 (0): dma buffer size 192512
DVB: registering new adapter (TT-Budget S2-3200 PCI)
adapter has MAC addr = 00:d0:5c:64:de:fa
input: Budget-CI dvb ir receiver saa7146 (0) as /class/input/input4
DVB: Unable to find symbol stb0899_attach()
budget-ci: A frontend driver was not found for device 1131/7146 subsystem 13c2/1019

What gcc version are you using?

Maybe there is a problem with my gcc or something like that...
but I can't imagine that, as the driver worked before the
"DVB_ATTACH for STB0899, STB6100, TDA8261" update...

I am using gcc version 4.2.2 (Gentoo 4.2.2 p1.0)

I have tried to compile the modules with kernel 2.6.23
and 2.6.21 - there was no difference.

The next thing I want to do is to compile the driver without the
"DVB_ATTACH for STB0899, STB6100, TDA8261" update...

Regards, Artem

Artem Makhutov
Unterort Str. 36
D-65760 Eschborn

More information about the linux-dvb mailing list