[linux-dvb] Pinnacle PCTV Sat HDTV Pro USB (PCTV452e)

Daniel Golle daniel.golle at gmail.com
Mon Oct 29 10:48:19 CET 2007

On Mon, Sun, 28 Oct 2007 23:13:20 +0000, garlicdevel at ntlworld.com wrote:
> > > wow you've managed to get this working?
> > > can you list which driver your using, and which version of stb0899
> > > I'm still trying to get video output from mine 
> > I use:
> > - Linux 2.6.22-ck1 on VIA Esther processor 1200MHz
> > - stb0899 from http://linuxtv.org/hg/~manu/stb0899/ (last change on
> > 10-10-2007)
> > - enable_pctv452e_20071021.patch posted by Dominik Kuhlen
> > - I changed the initial value of register STB0899_I2CRPT to 0x58 as
> > suggested by Dominik some hours after publishing the patch.
> > - szap2 from http://dev.kewl.org/hvr4000/utils/szap2.tgz finally did
> the
> > trick... (again, big thanks to Dominik for this hint!)
> > 
> > szap2 -r -c /home/daniel/channels.conf -i
> > tunes successfully to every DVB-S (but not -S2!) channel I ask it
> for.
> > I can play the stream in /dev/dvb/adapter0/dvr0 with mplayer
> (actually,
> > I do this on my router machine, the box the pinnacle is connected
> to:
> > cat /dev/dvb/adapter0/dvr0 | nc -l -p 12345
> > and this on my workstation:
> > nc 192.168.XXX.XXX 12345 | mplayer -stop-xscreensaver -v -vo xv -vf
> > tfields -
> > ).
> > 
> > got to restart netcat and mplayer everytime I tune to a different
> > channel. I guess, this is more a problem with mplayer not expecting
> the
> > TS to end/die unexpectedly...
> > 
> > Also, I tried to compile szap2 using the headers included in manu's
> > stb0899 code instead of the ones included in szap2, which did NOT
> work
> > (tuner doesn't lock to channel).
> > 
> > Anyway, just to mention, the LED seems to stay yellow at all times
> after
> > plugging the device, but i don't care as i cannot see it anyway ;)
> > 
> > btw: as dvbscan doesn't work yet with the new tuner api, I need an
> > up-to-date channels.conf for 19.2E. somebody, please run dvbscan 
> > and send me the result by email.
> > 
> > -Daniel
> thanks for the info this could save me a lot of time
> I've tried the above out but I'm still getting no output from dvr0
> at this point I'm not sure if it's because I'm using an amd64 system
> (perhaps non friendly 64bit code somewhere) or if the channel I'm
> trying to tune to is wrong in channels.conf
> can you let me know the channel details you've used to tune on Astra
> 19.2E (the line used in channels.conf)
> this way I can re-align the dish motor using an external decoder box
> then give it another go
basically, most channels i got in the channels.conf are working. as the
file is almost 8 months old (my ttpci died some time ago), I suppose
that the channels which are not working are really not there any more.
MTV Germany:11973:vC34:S19.2E:27500:4031+8190:4032:4034:0:28673:1:1078:0

both work perfectly (i mean it. saw a 90 minute movie on ARD yesterday

Sky News:11597:vC56:S19.2E:22000:305+131:306=eng:579:0:28707:1:1026:0

looses the lock every few milliseconds, resulting in typical
mpeg-glitches appearing in the picture from time to time (that may also
be because of the poor condition of my dish... even the ECCs got
limits). sometimes mplayer even refuses to start giving me this:
Checking for MPEG-TS...
TRIED UP TO POSITION 0, FOUND 47, packet_size= 188, SEEMS A TS? 1
GOOD CC: 12, BAD CC: 20
Checking for LMLM4 Stream Format
Invalid packet in LMLM4 stream: ch=18177 size=27537622
LMLM4 Stream Format not found

i will try to borrow an analog receiver from somewhere to check the
actual signal quality arriving from my dish, could be quite bad (i mean,
it looks bad, wasn't readjusted for at least 10 years and it's rusty all

If it still doesn't work for you, lets compare the tons of debugging
output in kern.log...


More information about the linux-dvb mailing list