[linux-dvb] AF9005 remote control

Moisés Pérez spir73 at gmail.com
Mon Sep 17 23:28:03 CEST 2007

2007/9/17, Luca Olivetti <luca at ventoso.org>:
> En/na Moisés Pérez ha escrit:
> [again, I ask you to keep the discussion on the mailing list ]

Sorry, but  gmail have sent the mail automatically to your personal mail, I
realized now....sorry!! (my first mail list)

> > I've tried configure lirc with af9005-remote and with af9005-lirc, but
> > when i try run irrecord, it says that lirc is not configured. In
> > /etc/lirc/hardware.conf, i don't know what driver must been used.
> below you say that you have an error loading dvb-usb-af9005-lirc.ko , so
> that's not suprising: if the module doesn't load it's not going to work
> [...]

Yes, below is explained

>  Seen that I can't configure lirc with af9005-lirc module and
> > af9005-remote doesn't work, I've tried to get the IR string but nothing
> > happens.
> >
> >  I've probed with af9005-remote and af9005-lirc (I know that would use
> > the first one) including the debug=1 option in module charging.
> >
> >     sudo rmmod -f dvb_usb_af9005_remote
> >     sudo modprobe dvb_usb_af9005_remote debug=1
> >
> >  Nothing appears on syslog pressing keys.
> so either your modprobe is ignoring command line switches (it happened
> to me), or you didn't enable debug while compiling the modules (if you
> use the mercurial tree I think it's enabled by default), or your syslog
> daemon is sending messages somewhere else.
> >     With af9005-lirc, charging it as here is explained
> > < http://www.linuxtv.org/pipermail/linux-dvb/2007-January/015612.html
> >,I've
> > gotten an error, I report it:
> >
> > $-sudo modprobe dvb-usb-af9005-lirc debug=1 > raw_code_log
> > FATAL: Error inserting dvb_usb_af9005_lirc
> > (/lib/modules/2.6.20-16-generic/kernel/drivers/media/dvb/dvb-usb/dvb-
> usb-af9005-lirc.ko):
> > Unknown symbol in module, or unknown parameter (see dmesg)
> Well, see dmesg to see what's the missing symbol. BTW, the redirection
> here does nothing (or maybe that's the cause for the error).

I've tried to load the af9005-lirc module with the device unplugged (to see
the debug) and it doesn't work, the error is the same

$ sudo modprobe dvb-usb-af9005-lirc debug=1
FATAL: Error inserting dvb_usb_af9005_lirc
usb-af9005-lirc.ko): Unknown symbol in module, or unknown parameter (see

[ 2953.248000] dvb_usb_af9005_lirc: Unknown symbol lirc_unregister_plugin
[ 2953.248000] dvb_usb_af9005_lirc: Unknown symbol lirc_register_plugin

My kernel version is 2.6.20-16-generic installed by apt-get from ubuntu
Lirc version is lirc-0.8.2, installed by apt-get too.
Should it work if I compile lirc instead of using pre-compiled packages?¿

>  Thank you very much for your help!!
> >  I thing that my remote is different of yours and it doesn't
> > work....neither with af9005-remote or with af9005-lirc (because I can't
> > [don't know how] configure it.
> with the dvb-usb-af9005-lirc module it should work with any remote, it's
> only (much) more convoluted to setup.

I see it!! But my remote (see it on
doesn't work correctly with the af9005-remote driver provided by linux-dvb
sources. It creates a input device that I can't get any input from it, or
directly doesn't appear the just created devide on my /dev/input.

Thanks for your help and sorry for not keeping the discussion on the list (I
haven't realized)...sorry to all!!

> --
> Luca
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20070917/da803a5a/attachment.htm 

More information about the linux-dvb mailing list