[linux-dvb] Strange DVB-T using scan and tzap FEC and Guard interval problems

Simon G linuxtv at simong.net
Wed Sep 26 21:55:09 CEST 2007


Our DVB-T network has once more been changed here in Karlstad, Sweden.
Once more I noticed strange behaviour with scan (atrpms linuxtv-dvb-apps
ver and tzap. It used to work without a problem

After creating a scan file with fec high, low and guard interval set to
auto I was able to scan a Mux for channels and create a channels.conf. I
knew the frequency(650MHz), the bandwidth(8MHz), the modulation (QAM64)
and the transmission-mode (8k).
However in trying to use the resulting channels.conf with tzap, I never
get a lock. I didn't know the FEC or guard interval part.

Now I have 2 different types of DVB-T cards. One Nova T 500 PCI
Dib0700(Yes I know, I have the latest firmware) and a TerraTec Cinergy
1200 DVB-T (SAA7146)

Using my favorite card (the 1200) i tried a frequency search in MythTV
using one of the mux frequencies and the other bits I knew. No luck :(
Then I tried the same using the Nova T 500. Yes it found and locked to
channels !

Anyway to cut a long story even longer ;) ...

I read the resulting entries in the mythtv database and edited my
channels.conf then tzap worked with both cards ??

scan was saying ...

when MythTV and tzap needed ...

ie. FEC_2_3 and GUARD_INTERVAL_1_8 were needed for tzap and MythTV using
scan again with a few -vvv gave this ...

parse_terrestrial_delivery_system_descriptor:498: 0x3184/0x3fd

ie. the wrong?? FEC and GUARD interval

Anybody know whats going on here ?? Is the network sending wrong info ??


Simon G.

More information about the linux-dvb mailing list