[linux-dvb] Help installing with S2-3200 or with TW1034

Dmitry Podyachev vdp at teletec.com.ua
Thu Aug 21 12:35:30 CEST 2008

Problem with /dev/dvb/adapterX/ca0 at Twinhan-1034 with CI and with
Technotrend S2-3200+CI.
I try http://www.twinhan.com/files/AW/Linux/AZLinux_v1.4.2_CI_FC6.tar.gz
and http://www.twinhan.com/files/AW/Linux/AZLinux_v1.5_CI_FC6.tar.gz
but not on Fedora6,but with the same linux-kernel: linux- and
linux- CI don't work (invalid PC card inserted message)
the same CAM-module (viaccess red label) and chip card ("poverhnost")
worked properly with Skystar1-ci.
Next I installed last v4l and try it with kernel,
linux-2.6.26 and linux-2.6.27:

git clone

hg clone http://jusst.de/hg/multiproto_plus
hg clone http://linuxtv.org/hg/v4l-dvb
hg clone http://linuxtv.org/hg/dvb-apps

then try other
hg clone http://jusst.de/hg/multiproto
and multiproto_plus

and always cp /usr/src/linux-next/.config /tmp
make mrproper
cp /tmp/.config .
make clean;make bzImage;make modules;make modules_install;make install
&& reboot

when I try load budget_ci or saa, message like that:
modprobe saa7134
WARNING: Error inserting compat_ioctl32
Invalid module format
WARNING: Error inserting v4l1_compat
Invalid argument
WARNING: Error inserting videodev
Invalid module format
The relevant part of dmesg:
kernel: compat_ioctl32: exports duplicate symbol v4l_compat_ioctl32
(owned by kernel)
kernel: v4l1_compat: module is already loaded
kernel: videodev: exports duplicate symbol video_device_alloc (owned by

or with en50221 - invalid pc card inserted

everywhere I have't successful result.
Next I try mantis v4l and here stb0899 error

Can anybody help me out with my installation? I've tried both the latest
git (linux-next) and v4l2, mantis_v4l. I have no idea what to do.

Thank you in advance, Dmitry

More information about the linux-dvb mailing list