[linux-dvb] Any chance of help with v4l-dvb-experimental / Avermedia A16D please?

Richard (MQ) osl2008 at googlemail.com
Sun Feb 3 16:07:27 CET 2008

I tried contacting Markus with the following but no response - probably
one of you experienced coders on this list will know what's wrong
though? As I say below, the 'standard' v4l-dvb builds fine but is no use
with this card.

Richard (MQ)

> Having another try to get my Avermedia A16D card working with latest hg
> code. I'm also using the very latest OpenSuSE 'factory' platform, with
> kernel 2.6.24-rc8-git2-5-default. gcc is 4.3.0
> I can build the 'standard' v4l-dvb tree OK, though as expected it
> doesn't see my card. However, when I try to build your
> v4l-dvb-experimental tree (in a separate directory) I get
>> > rpm at DevBox2400:~/Progs/v4l-dvb-experimental/v4l> make
> ...
>> > make -C ../../../linux-2.6.24-rc8-git2-5 O=../linux-2.6.24-rc8-git2-5-obj/i386/default modules
>> >   CC [M]  /home/rpm/Progs/v4l-dvb-experimental/v4l/flexcop-pci.o
>> > In file included from /home/rpm/Progs/v4l-dvb-experimental/v4l/flexcop-common.h:23,
>> >                  from /home/rpm/Progs/v4l-dvb-experimental/v4l/flexcop-pci.c:10:
>> > /home/rpm/Progs/v4l-dvb-experimental/v4l/dvb_frontend.h:42:33: error: media/v4l_dvb_tuner.h: No such file or directory
> Indeed there's no directory 'media' at the current level, though there's
> one at ../linux, so I tried
>> > ln -s ../linux/include/media media
> Now make gets a bit further, but dies building bttv-driver
> Please have you any suggestions?
> By the way - is it more appropriate to post this e.g. at linux-dvb?
> Many thanks
> Richard.

More information about the linux-dvb mailing list