[linux-dvb] Help! I cant view video. BUT I can scan!!

Per Blomqvist p.blomqvist at lsn.se
Thu Feb 7 22:30:13 CET 2008

Hello, help!

I can "dvbscan" and  "tzap", and gets indication of a good signal. BUT, 
I cant view the video!
(from the dvb device)

Also "dvbdate" command works (that returns time and date from the air, I 
presume). But not a command as "dvbsnoop" (that need 

A sample: ( Its step by step of your guide:
http://www.linuxtv.org/wiki/index.php/Testing_your_DVB_device )

In one console I run: /.tzap# tzap -r -c channels.conf "TV4 Öresund" ( 
and are getting lines as:
status 1f | signal c3c3 | snr ffff | ber 0000004a | unc 00000000 | 
status 1f | signal c3c3 | snr ffff | ber 0000004e | unc 00000000 | 
AND in another console:
mplayer -v /dev/dvb/adapter0/dvr0
(thats basically halts without any further information)

ALSO if I type: "cat /dev/dvb/adapter0/dvr0 > afile.txt"
(But then again, "afile.txt" remains empty)

Conclusion, /dev/dvb/adapter0/dvr0 never returns anything. This 
"/dev/dvb/adapter0/dvr" isnt proper. Must be a Linux-kernel/module 

Here are some further info of whats on my system:

* Media Card: "Asus P7131 Hybrid"
(This very same Media-card worked on an older machine, an old Pentium, 
that I now abandoned. Maybe I used the line "card=112 i2c_scan=1 
tunar=54 gpio_tracking=1" when loading "saa7134" kernel-module, for 
this. By a gento wiki-tips (http://gentoo-wiki.com/HARDWARE_saa7134). I 
tested this line on this AMD64 machine also, but didnt make any 

* Linux-kernel, "2.6.22-3-amd64" (The only kernel I see in my 
Debian-testing apt list, cant use any other kernel, strange also..)

* The system, Its some dual AMD64, mother-board Asus "M2A-VM HDMI" (a 
card with most stuff built-in, as sound graphics.. etc) A common card 
(for building computers aimed toward media, as this is).

* Mplayer (for what its matter, gnu "cat" dint work ether, so it doesnt 
matter). I have compiled Mplayer myself, with everything possible 
included. Also, I have tested Debians deb-package called the same name, 
but without success (or difference).

Maybe I could include the returns of the old and new "lsmod", but the 
only difference there regarding this is, that I now dont use Alsa (sound 
system). Now I use the default outof-the-box-configurations (a fresh 
installation, this my system is, now). So I dont include what "lsmod" 
returns, in this email (because then I can continue with "lspci" "dmsg", 
and all possible and impossible sniff logs..  I dont know what may be 
relevant info, to solve this.

Any comments and Ideers are welcome! !


I just signed up for this mailing-list ( I hope this is the right 
forum.. thanx again. Also I hope the solution is simple.

Mvh, Per Blomqvist
Web: http://phoohb.shellkonto.se
Telnr: +46 70-3355632

More information about the linux-dvb mailing list