[linux-dvb] conflicts between v4l-dvb and out of tree modules

Filippo Argiolas filippo.argiolas at gmail.com
Sun Feb 24 22:10:58 CET 2008

Hi since I've installed v4l-dvb drivers from the hg tree to make my
nova-t stick work, my webcam based on uvcvideo drivers stopped working
complaining about unknown symbol errors.
I ran make kernel-links and tried to recompile uvcvideo module. Even
with a freshly compiled module the unknown symbol error still stood.
You can find a summary of the problem in the linux-uvc mailing list with
the solution I've found:

I don't know too much about kernel development but it seems that
Module.symvers file contains a checksum of all the exported symbols.
This file is updated in the hg mercurial tree but not in the linux build
dir so external modules are compiled with outdated symbol versions.
Is there a way to update symbols in in /lib/modules/`uname
-r`/build/Module.symvers? maybe something like this should be done in
the makelinks.sh scripts?
Please note that, looking for a solution, I've many unaswered questions
from v4l-dvb and em28xx users complaining that their webcam stopped
working. So it's not an uncommon issue.


More information about the linux-dvb mailing list