[linux-dvb] cx88-input: leadtek tv200xp global

Frühwald Szabolcs szab100 at bytestorm.hu
Tue Feb 26 11:57:23 CET 2008

hi there,

i've a leadtek tv2000xp global pci card
it's running OK (with some errors, but works) with current developement
v4l-dvb branch
i tried to enable it's IR remote control too in cx88-input.c
just copied tv2000xp expert switch entry:

                 ir_codes = ir_codes_winfast;
                 ir->gpio_addr = MO_GP0_IO;
                 ir->mask_keycode = 0x8f8;
                 ir->mask_keyup = 0x100;
                 ir->polling = 1; /* ms */

but the result of this was: IR recognized well by kernel, dev/input
device attached
but when i pressed a button on remote, it printed its character, waited
a sec and started to repeat this character forever
so, i pressed '6', out was:
6<1sec_delay>666666666666666666666666666666666666666666666666666 .... etc..
could anybody help me to correct this?
it would be cool if i could paste a patch to the mailing list to enable
this functionality for this card
i figured out the main problem is with "ir->mask_keyup=0x100", so maybe
it isn't there... but i didnt find it at 0x60,0x80 too and don't know
where could it be??

ps: I also tried to comment out this line of code (as i saw some other
entrys without this option), the repeats are stopped but when i pressed
a button more than once it's only showed up once. So, i pressed 6,
printed 6 but when i pressed 6 again, it didnt print anything. After i
pressed other button (printed once too), and pressed again 6, prints 6

Thanks for your help...


More information about the linux-dvb mailing list