[linux-dvb] Nova-t remote stopped working (budget_ci rc5_device not set?)

Kevin Page linux-dvb-list at krp.org.uk
Sun Jan 6 04:14:59 CET 2008


I'm running a pretty standard Fedora 7 box with MythTV. Recently my
remote control, plugged into a SAA7146 era Nova-T, stopped working. I'm
fairly sure this was after a reboot, probably into a new kernel which
had been installed at some previous time (reboots are infrequent).

The kernel is

After much searching, I tried enabling the ir_debug option on the
budget_ci module. This showed me that the ir signals were still being
received, but for some reason were no longer generating input events to
be picked up by lirc.

I then looked at the rc5_device parameter. This was, by default, set to
-1. If I changed it to 255/"any device" then keycodes are generated and
lirc works again.

A few questions:
1) Is -1 the "autodetect" value for rc5_device? If so, which remote
should be autodetected for the Nova-T? (I have both the smaller black
Hauppauge remote, and a black/grey one - neither worked by default)

2) How do I work out the value of rc5_device for my remotes? I've found
mention of looking at the ir_debug output, but no instruction of how to
interpret it.

3) Would this change have hit mainline kernels fairly recently - perhaps
between 2.6.22 and 2.6.23? I'm wondering if this is a full or partial
explanation of the breakage.

4) Does this mean I could expect the Nova-T receiver to work with an RC5
protocol remote? For some reason I'd always thought it would only work
with the Hauppage supplied remote.

Many thanks,


More information about the linux-dvb mailing list