[linux-dvb] System fails to boot on adding second DVB-T PCI card

hermann pitton hermann-pitton at arcor.de
Wed Jan 9 19:25:25 CET 2008

Am Samstag, den 05.01.2008, 09:17 +0000 schrieb John Pilkington:
> Hi:  I'm running MythTV 0.21 under CentOS 5, all updated  from ATrpms  etc.
> The DVB-T card is 'AVerTV DVB-T Super 007', which worked out-of-the-box 
> after I had used the get_dvb_fimware script packaged in kernel-docs.  
> Manual extraction, as mentioned in the wiki, didn't give a usable file.
> I have a second identical card which I would like to add, but with it in 
> place booting stops with a blank screen soon after the udev stage.  That 
> reports a malformed kmdl, but with one card this is presumably corrected 
> after the firmware load.  I don't see any jumpers on the card.
> I also have a Medion 7134 card in place; I intend to use its SVHS input 
> but at present it isn't much used. I mention it because all the devices 
> include an saa7134.
> My apologies if this is a well-known effect, but I don't recollect 
> seeing it mentioned and would like to get it fixed.  Thanks in advance.
> John Pilkington

Hi John,

still no solution?

Put in /etc/modprobe.conf
options saa7134 card=118,118 tuner=54,54 gbuffers=32 latency=64
Do a "depmod -a"

Power down, remove all power and the md7134,
especially if not in the original blue PCI slot.

Are you able to come up now?

If so, "modprobe -vr saa7134-dvb tuner tda827x" and
"modprobe -v saa7134" several times.

Have a look in "dmesg" if the eeprom readout is always the same.

There seems to be a potential issue, if multiple cards with eeprom
detection are in the same machine, the readout is sometimes corrupted.

This must not be related to your issue, but please test.

Anyway, the card is unnecessarily in the Philips' reference boards
eeprom detection if auto detected.

I'll provide a patch to remove it from there.


More information about the linux-dvb mailing list