[linux-dvb] How can I ever succeed using DVB-T on Gentoo Linux?

Jesper Taxbøl jesper at taxboel.dk
Tue Jan 22 21:07:06 CET 2008

Hi guys,

I have been trying to get DVB working under Gentoo for quite some time
now. At first my goal was to receive encrypted DVB-S through a PCI
card. That adventure took me through a list of cards:

Terratec Cinergy  without a CAM module - this could recieve Free TV
Pinnacle systems card with a CAM module - This could only recieve free TV
Hauppauge-NEXUS-S card without a CAM module
Hauppauge-NOVA-S with a CAM module.

I actually made the last one work, but it could only tune for about 15
minutes and I often needed to coldstart the PC. I gave up on the DVB-S
units almost a year ago and have now moved toward DVB-T cards, hoping
that life without a CAM module is easier. Denmark recently started
DVB-T services. This adventure has now taken me through 4 different

A pinnacle stick (USB ID: eb1a:2870) that only seem to reveal a analog
tuner. So no luck with that yet.
A AGK stick (USB ID: 15a4:9020), that is recognized as an af9005
device, but it cant scan any services.
Two Hauppauge Nova-T-USB sticks (2040:7070). that could scan and tune,
but had alot of noise in the signal. I tried variuous firmwares that
finally ended up killing one of the units.
A Hauppauge NOVA-T-PCI, which sort of works but there is a lot of
noise in the signal.

I feel I am getting closer, but it is very frustrating to spend alot
of time and money getting nowhere. So i figured I would try to explain
what I have done, hoping for someone to point out some obvious

I have tried a range of PC's using Gentoo on all of them. The one I
use now is a Core2 Duo running "i686 mode". (I tried installing an
Amd64 profile, but that really made the mercurial v4l-dvb package

I do a normal gentoo stage3 install following
On top of that i have installed "vanilla-sources", so my kernel is

Then I fetch the v4l-dvb and dvb-apps packages (as root) using:

hg clone http://linuxtv.org/hg/v4l-dvb

hg clone http://linuxtv.org/hg/dvb-apps

then i do make && make install in both of the directories and reboot.

Then I enter the v4l-dvb directory and do a "make reload". This seem
to load modules, but with very mixed results.

I read "dmesg" to see if my device has been detected.

If this wakes up one of my devices I usually do a scan for channels using:

scan /usr/share/dvb/dvb-t/dk-All
(I usually use one device at a time, to avoid mixups)

This evening this procedure revealed a poor subset of the channels I
know is available in my signal. All very noisy.

I try to record using:

gnutv -out file test.mpg -timeout 5400 DR1

Thereafter i play it using VLC

vlc test.mpg

This reveals a noisy video stream. Sound is skipping and the image is
very distorted.

I have some ideas on where the error lies, but not the knowledge to
proceed so I have cooked up some questions:

1) What is the right kernel to use with the latest v4l-dvb checkout,
and where can I figure out which to use.

2) What is the proper firmware for DVB cards. I killed a Nova-T-USB
stick trying a bad firmware, and I suspect bad firmwares to be partly
responsible for some of my problems. How do I make sure I have the
right firmware?

3) Is the ForwardErrorCorrection algorithm not supported by the
v4l-dvb drivers. I get crisp images on Windows, but noisy on Linux?

4) What is the proper procedure for rebuilding and installing the
v4l-dvb modules.

"Make menuconfig" in the v4l-dvb directory gives me some options. What
should I enable. And perhaps more important what should be disabled in
the kernel menuconfig.

Should I do something after the modules are built?

What is the proper way to give modules options?

How do I clean out old modules?

I sure could use some guidance here.

I hope my explanation pops up some obvious reason for my poor results
and perhaps some answers.

Thank you in advance, and sorry for the lengthy mail.

Jesper Taxbøl

More information about the linux-dvb mailing list