[linux-dvb] HVR-4000 - cx8802_start_dma() Failed. Unsupported value in .mpeg (0x00000001)

Marshall, Russ rmarshall at tandbergtv.com
Thu Jan 24 17:54:18 CET 2008

That worked!  thanks!  Is there a more graceful way around this so that
I don't have to run szap continuously while receiving data?


-----Original Message-----
From: Steven Toth [mailto:stoth at linuxtv.org] 
Sent: Thursday, January 24, 2008 10:44 AM
To: Marshall, Russ
Cc: linux-dvb at linuxtv.org
Subject: Re: [linux-dvb] HVR-4000 - cx8802_start_dma() Failed.
Unsupported value in .mpeg (0x00000001)

Marshall, Russ wrote:
> Maybe someone on here can provide some insight on this.  I'm trying to

> do MPE over DVB-S and S2 with the HVR-4000.  I'm currently using
> and have tried both the multiproto tree with the 
> HVR-4000-DVR patch and the main v4l-dvb tree with Darron's patch, both

> with the same result.  The drivers and firmware load fine, scan 
> doesn't return any pids but does appear to tune, szap seems to lock.  
> If I try to use dvbnet to bind an interface to a pid or do a dvbsnoop 
> of the pid I get the following error:
> cx8802_start_dma() Failed. Unsupported value in .mpeg (0x00000001)
> Can anyone provide any insight on to what might cause this?  I have a 
> Cerona SkyDSR hooked up to the same feed and can receive everything 
> just fine.  This happens with the card in both S and S2 modes.

It means the dvb sub-driver hasn't claimed the IRQ, probably because the
demux was not opened (which indirectly causes the dubdriver to claim

The errors is reported because someone asked DMA to start, but no
subdriver owns the transport bus.

Try opening the demux using szap -r.

- Steve

More information about the linux-dvb mailing list