[linux-dvb] HVR-4000 - cx8802_start_dma() Failed. Unsupported value in .mpeg (0x00000001)

Steven Toth stoth at linuxtv.org
Thu Jan 24 18:36:51 CET 2008

Marshall, Russ wrote:
> That worked!  thanks!  Is there a more graceful way around this so that
> I don't have to run szap continuously while receiving data?
> --
> Russ
> -----Original Message-----
> From: Steven Toth [mailto:stoth at linuxtv.org] 
> Sent: Thursday, January 24, 2008 10:44 AM
> To: Marshall, Russ
> Cc: linux-dvb at linuxtv.org
> Subject: Re: [linux-dvb] HVR-4000 - cx8802_start_dma() Failed.
> Unsupported value in .mpeg (0x00000001)
> Marshall, Russ wrote:
>> Maybe someone on here can provide some insight on this.  I'm trying to
>> do MPE over DVB-S and S2 with the HVR-4000.  I'm currently using
>> and have tried both the multiproto tree with the 
>> HVR-4000-DVR patch and the main v4l-dvb tree with Darron's patch, both
>> with the same result.  The drivers and firmware load fine, scan 
>> doesn't return any pids but does appear to tune, szap seems to lock.  
>> If I try to use dvbnet to bind an interface to a pid or do a dvbsnoop 
>> of the pid I get the following error:
>> cx8802_start_dma() Failed. Unsupported value in .mpeg (0x00000001)
>> Can anyone provide any insight on to what might cause this?  I have a 
>> Cerona SkyDSR hooked up to the same feed and can receive everything 
>> just fine.  This happens with the card in both S and S2 modes.
> It means the dvb sub-driver hasn't claimed the IRQ, probably because the
> demux was not opened (which indirectly causes the dubdriver to claim
> ownership).
> The errors is reported because someone asked DMA to start, but no
> subdriver owns the transport bus.
> Try opening the demux using szap -r.

Don't top post, always reply to the bottom of the thread or inline.

No idea, possibly, this is likely a common problem on many different 
bridge drivers if/when the demux is closed and the demux is released.

How do you plan to tune the app anyway? Why not have that app monitor 
the signal strength and thus keep the device open?

It's not clear whether changing the default thread value (module param - 
exact name escapes me) for closing the  frontend will help here also. 
(The module parameter defaults to automatically close the frontend after 
3 seconds of idle time).... Try increasing it.

- Steve

More information about the linux-dvb mailing list