[linux-dvb] af9015 driver fails on ubuntu 8.04 / alink dtu-m

Antti Palosaari crope at iki.fi
Fri Jul 4 19:20:51 CEST 2008

Peter Parkkali wrote:
> Moi,
> On 3.7.2008, at 15:08, Antti Palosaari wrote:
>>> Since upgrading to Ubuntu 8.04 (Linux 2.6.24-19), I haven't been  
>>> able  to get Antti's af9015 driver to work with the a-link's  
>>> "DTU(m)" dongle  (USB 15a4:9016). I'm using the latest version from http://linuxtv.org/hg/ 
>>>  ~anttip/af9015/ . An older version of the driver did work earlier  
>>> this  year on Ubuntu 7.10 with the same stick, however.
>> From the logs I see that you have USB1.1. Could you comment out  
>> USB1.1 stuff from af9015_read_config -function and test if it  
>> resolves issue you have. Function is inside of the af9015.c -file.
> I tried it, and it produces exactly the same kind of errors as before.  
> However, this time VLC doesn't crash - it just keeps on sending the  
> garbled stream out. (Could be a coincidence - the receiving vlc did  
> eventually crash.)
> I tried connecting it via a USB 2 adapter, and there it works 99% of  
> the time :) although there are still some glitches in the picture and  
> sound. Both vlc and kernel still print the same messages when running,  
> but there are fewer,  about 10-20 lines after running for ~10 min.
> - peter

Do you have any USB2.0 port to test?
When I implemented PID-filter for USB1.1 I reached also similar problem, 
but that was only for broadcasting MUX A in Finland. With other muxes I 
tested it was OK. I don't know why. Can you ensure that problems are 
only when viewing MUX A programs?
Anyhow, USB2.0 port and without PID-filtering your device should work 
like a charm.

When I get some time I will test and sniff how windows driver does 


More information about the linux-dvb mailing list