[linux-dvb] KNC TV Station DVR Tuner Sound Issue

Frederic CAND frederic.cand at anevia.com
Tue May 6 09:54:26 CEST 2008

Frederic CAND a écrit :
> Frederic CAND a écrit :
>> hermann pitton a écrit :
>>> Am Mittwoch, den 30.04.2008, 16:45 +0200 schrieb Frederic CAND: 
>>>> Frederic CAND a écrit :
>>>>> Frederic CAND a écrit :
>>>>>> hermann pitton a écrit :
>>>>>>> Am Dienstag, den 29.04.2008, 14:18 +0200 schrieb Frederic CAND:
>>>>>>>> hermann pitton a écrit :
>>>>>>>>> Hi Frederic,
>>>>>>>>> Am Dienstag, den 29.04.2008, 11:09 +0200 schrieb Frederic CAND:
>>>>>>>>>> Dear all,
>>>>>>>>>> I recently had to change v4l drivers to support my WinTV HVR 1300.
>>>>>>>>>> I have issues making my HVR work but that's not the point here.
>>>>>>>>>> My problem is that since I updated kernel + drivers, I can't manage to 
>>>>>>>>>> make sound work when I'm using the tuner input. Sound jack input works 
>>>>>>>>>> when I'm using SVideo or Composite Video, but not when I'm using tuner.
>>>>>>>>>> Here are the options I'm using
>>>>>>>>>> tuner : port2=0
>>>>>>>>>> saa7134: oss=1 disable_ir=1
>>>>>>>>>> saa7134-oss: rate=48000
>>>>>>>>> the rate=48000 is only valid for external analog input and disables
>>>>>>>>> sound from tuner. Have a look at the saa7134-oss mixer under such
>>>>>>>>> conditions.
>>>>>>>>> You must use default rate of 32000 for dma sound from tuner.
>>>>>>>>> The saa7134-oss is also soon deprecated and replaced by saa7134-alsa.
>>>>>>>>> If you are considering using recent v4l-dvb mercurial stuff, which
>>>>>>>>> should be best for the HVR1300 and reporting bugs on saa7134-empress,
>>>>>>>>> you might still have your old saa7134-oss module around and some others
>>>>>>>>> like the old video_buf now loaded, since not deleted on upgrade.
>>>>>>>>> After make rmmod and rminstall with current v4l-dvb you should delete
>>>>>>>>> such remaining modules on older kernels too before make install.
>>>>>>>>> Cheers,
>>>>>>>>> Hermann
>>>>>>>> hum I used to set rate to 48000 with my old 2005 july snapshot and it 
>>>>>>>> was working even with tuner ... but ok I'll try 32000
>>>>>>>> i've tried alsa and I had the same results, that is no sound with tuner 
>>>>>>>> but line in sound with composite and svideo
>>>>>>>> do I need some special stuffs compiled in my kernel except from config_snd ?
>>>>>>>> about old modules still loaded this can't be since I build my system 
>>>>>>>> from scratch each time i try a new kernel / driver into an ext2 file, 
>>>>>>>> which I put on a 32MB flash disk and boot on it ... so I'm sure I'm not 
>>>>>>>> using my old v4l snapshot, but the v4l drivers
>>>>>>>> I'll let you know if I can make it work
>>>>>>> Ah, you are in France!
>>>>>> yeah!
>>>>>>> Try "modinfo saa7134". Due to unresolvable auto detection issues between
>>>>>>> different SECAM standards there was a secam= either DK, L or Lc option
>>>>>>> introduced.
>>>>>> huhu... but my system has to work worldwide ... so a module option is 
>>>>>> not a good idea, because it does not only depends on the country, but 
>>>>>> also if my customer is using a signal modulator or not, ... and I have 
>>>>>> two cards in my system, and I want to be able to select a certain SECAM 
>>>>>> mode with the first one, and another mode with the second card
>>>>>> Actually I'm selecting secam L, DK or BG with an ioctl cause my card can 
>>>>>> handle them (tested and working with older drivers/kernels)
>>>>>>> Anything else then 32000Hz sampling rate for TV is wrong currently and
>>>>>>> you get that input disabled on saa7134-oss mixer. Yes, it was once
>>>>>>> possible, but not intended, to use 48000 also for TV/Video on saa7134
>>>>>>> chips, but gave very poor and crackling sound and is wrong.
>>>>>>> The current saa7134-alsa is simpler to use and also uses an exported
>>>>>>> mute symbol from saa7134-tvaudio. Default distribution settings are
>>>>>>> sufficient. On recent Ubutu releases seem to be problems with an out of
>>>>>>> tree alsa there.
>>>>>> Ok I'll see with this rate thing and let you know
>>>>>>> Cheers,
>>>>>>> Hermann
>>>>>> Greetings.
>>>>> I still have nothing with oss and rate=32000, with alsa, or with secam=l
>>>>> Anyway, some more informations :
>>>>> * I've got the following error messages on saa7134 module insertion
>>>>> saa7134_empress: Unknown symbol saa7134_devlist
>>>>> saa7134_empress: Unknown symbol saa7134_common_ioctl
>>>>> saa7134_empress: Unknown symbol saa7134_boards
>>>>> saa7134_empress: Unknown symbol saa7134_ts_register
>>>>> saa7134_empress: Unknown symbol saa7134_ts_qops
>>>>> saa7134_empress: Unknown symbol saa7134_i2c_call_clients
>>>>> saa7134_empress: Unknown symbol saa7134_ts_unregister
>>>>> saa7134_alsa: Unknown symbol saa7134_tvaudio_setmute
>>>>> saa7134_alsa: Unknown symbol saa_dsp_writel
>>>>> saa7134_alsa: Unknown symbol saa7134_devlist
>>>>> saa7134_alsa: Unknown symbol saa7134_pgtable_alloc
>>>>> saa7134_alsa: Unknown symbol saa7134_pgtable_build
>>>>> saa7134_alsa: Unknown symbol saa7134_pgtable_free
>>>>> saa7134_alsa: Unknown symbol saa7134_dmasound_init
>>>>> saa7134_alsa: Unknown symbol saa7134_dmasound_exit
>>>>> saa7134_alsa: Unknown symbol saa7134_set_dmabits
>>>>> saa7134 ALSA driver for DMA sound loaded
>>>>> saa7134[0]/alsa: saa7134[0] at 0xe5300000 irq 5 registered as card -1
>>>>> saa7134[1]/alsa: saa7134[1] at 0xe5301000 irq 9 registered as card -1
>>>>> * When using audio_debug=1 for saa7134, I've got the following :
>>>>> saa7134[1]/audio: mute/input: nothing to do [mute=1,input=Television]
>>>>> saa7134[1]/audio: sound IF not in use, skipping scan
>>>>> saa7134[1]/audio: mute/input: nothing to do [mute=1,input=Television]
>>>>> saa7134[1]/audio: mute/input: nothing to do [mute=1,input=Television]
>>>>> saa7134[1]/audio: ctl_mute=0 automute=0 input=Television  =>  mute=0 
>>>>> input=Television
>>>>> saa7134[1]/audio: sound IF not in use, skipping scan
>>>>> saa7134[1]/audio: mute/input: nothing to do [mute=0,input=Television]
>>>>> saa7134[1]/audio: sound IF not in use, skipping scan
>>>>> saa7134[1]/audio: mute/input: nothing to do [mute=0,input=Television]
>>>>> saa7134[1]/audio: ctl_mute=0 automute=1 input=Television  =>  mute=1 
>>>>> input=Television
>>>>> saa7134[1]/audio: sound IF not in use, skipping scan
>>>>> saa7134[1]/audio: ctl_mute=0 automute=0 input=Television  =>  mute=0 
>>>>> input=Television
>>>> Did I mention I'm using ?
>>> Hi,
>>> yes, that is the annoying part ;), but still fine, since others have
>>> been already restless on getting support with latest drivers on a
>>> 2.4.18 ! without to provide a single line of code themselves ...
>>> This is completely different with you, but we have other issues too.
>>> http://linuxtv.org/hg/v4l-dvb/rev/d6660f8c6dbb
>>> You might try to clean your /media modules and try with that snapshot.
>>> Not compile tested for 2.6.22, but might fit. Click on bz2 or gz on top.
>> ok, I'll have a look at this asap
>>> Of course, if not auto detected you can select each TV analog standard
>>> separately for each card you have, but selectable SECAM was new.
>>> Do you have any progress on it or are you seriously asking me to look at
>>> a
>> My concern is to use any kernel while having full support for my knc tv 
>> station dvr AND my Hauppauge HVR 1300 ... that is, sound and mpeg 
>> compression
>> I was using a 'til now, with an old v4l (not v4l-dvb) snapshot 
>> so ... if I can still use my and have support for my knc and 
>> my hauppauge within the same system, I'll be the happiest man (changing 
>> kernel is not an idea we like since by doing that we'll need time to 
>> test uptime equipments before releasing a new version of our products, ...)
>> is not mandatory but I know some things changed between 2.6.16 
>> and recent kernels regarding modules (synopsis of some functions 
>> changed, ...) so adapting a recent snapshot against 2.6.16 might be 
>> painful ...
>>> You might remember, I'm interested at the point, the encoder gave up.
>> huhu, I know that
>> I'll build 2.6.16 to 2.6.21 kernels this morning to see if my knc have 
>> sound in any of them with the modules included in the kernels (i.e I 
>> won't use my 2005 v4l snapshot) and let you know
> I can't get sound when selecting tuner with drivers included in kernel 
> ... whether I use alsa or oss
> options used :
> tda9887: port2=0
> saa7134-oss : rate=32000 or rate=48000 (same results)
> saa7134: disable_ir=1 oss=1
> or
> tda9887: port2=0
> saa7134: disable_ir=1 alsa=1
> I tried without port2=0, same results ...
>> what do you mean by "the encoder gave up" ?
>>> Cheers,
>>> Hermann
>> Regards

tests results :


sound working with tuner, saa7134 options are oss=1 oss_rate=48000 
(32000 works too)

Unable to handle kernel paging request at virtual address ...
Modules linked in: saa7134_empress saa7134  ...

ok !!!!

------------[ cut here ]------------
kernel BUG at <bad filename>:57323!
invalid operand: 0000 [#1]
Modules linked in: saa7134_empress saa7134 ....
Code: 07 83 c4 08 c3 8d 76 00 8b 42 08 40 78 1d b8 ff ff ff ff 89 44 24 
04 c7 04 24 10 00 00 00 e8 15 07 ff ff 83 c4 08 c3 0f 0b eb cb <0f> 0b 
eb df 89 f6 8d bc 27 00 00 00 00 83 ec 20 89 74 24 14 8b
  <1>Fixing recursive fault but reboot is needed!

huhum !!!


does not crach, but no sound when using tuner, whether I use rate=32000 
or rate=48000 ... oss part has been moved to a new module : saa7134-oss ...

CAND Frederic
Product Manager

More information about the linux-dvb mailing list