[linux-dvb] KNC TV Station DVR Tuner Sound Issue

Frederic CAND frederic.cand at anevia.com
Tue May 6 15:25:14 CEST 2008

hermann pitton a écrit :
> Am Mittwoch, den 30.04.2008, 16:45 +0200 schrieb Frederic CAND: 
>> Frederic CAND a écrit :
>>> Frederic CAND a écrit :
>>>> hermann pitton a écrit :
>>>>> Am Dienstag, den 29.04.2008, 14:18 +0200 schrieb Frederic CAND:
>>>>>> hermann pitton a écrit :
>>>>>>> Hi Frederic,
>>>>>>> Am Dienstag, den 29.04.2008, 11:09 +0200 schrieb Frederic CAND:
>>>>>>>> Dear all,
>>>>>>>> I recently had to change v4l drivers to support my WinTV HVR 1300.
>>>>>>>> I have issues making my HVR work but that's not the point here.
>>>>>>>> My problem is that since I updated kernel + drivers, I can't manage to 
>>>>>>>> make sound work when I'm using the tuner input. Sound jack input works 
>>>>>>>> when I'm using SVideo or Composite Video, but not when I'm using tuner.
>>>>>>>> Here are the options I'm using
>>>>>>>> tuner : port2=0
>>>>>>>> saa7134: oss=1 disable_ir=1
>>>>>>>> saa7134-oss: rate=48000
>>>>>>> the rate=48000 is only valid for external analog input and disables
>>>>>>> sound from tuner. Have a look at the saa7134-oss mixer under such
>>>>>>> conditions.
>>>>>>> You must use default rate of 32000 for dma sound from tuner.
>>>>>>> The saa7134-oss is also soon deprecated and replaced by saa7134-alsa.
>>>>>>> If you are considering using recent v4l-dvb mercurial stuff, which
>>>>>>> should be best for the HVR1300 and reporting bugs on saa7134-empress,
>>>>>>> you might still have your old saa7134-oss module around and some others
>>>>>>> like the old video_buf now loaded, since not deleted on upgrade.
>>>>>>> After make rmmod and rminstall with current v4l-dvb you should delete
>>>>>>> such remaining modules on older kernels too before make install.
>>>>>>> Cheers,
>>>>>>> Hermann
>>>>>> hum I used to set rate to 48000 with my old 2005 july snapshot and it 
>>>>>> was working even with tuner ... but ok I'll try 32000
>>>>>> i've tried alsa and I had the same results, that is no sound with tuner 
>>>>>> but line in sound with composite and svideo
>>>>>> do I need some special stuffs compiled in my kernel except from config_snd ?
>>>>>> about old modules still loaded this can't be since I build my system 
>>>>>> from scratch each time i try a new kernel / driver into an ext2 file, 
>>>>>> which I put on a 32MB flash disk and boot on it ... so I'm sure I'm not 
>>>>>> using my old v4l snapshot, but the v4l drivers
>>>>>> I'll let you know if I can make it work
>>>>> Ah, you are in France!
>>>> yeah!
>>>>> Try "modinfo saa7134". Due to unresolvable auto detection issues between
>>>>> different SECAM standards there was a secam= either DK, L or Lc option
>>>>> introduced.
>>>> huhu... but my system has to work worldwide ... so a module option is 
>>>> not a good idea, because it does not only depends on the country, but 
>>>> also if my customer is using a signal modulator or not, ... and I have 
>>>> two cards in my system, and I want to be able to select a certain SECAM 
>>>> mode with the first one, and another mode with the second card
>>>> Actually I'm selecting secam L, DK or BG with an ioctl cause my card can 
>>>> handle them (tested and working with older drivers/kernels)
>>>>> Anything else then 32000Hz sampling rate for TV is wrong currently and
>>>>> you get that input disabled on saa7134-oss mixer. Yes, it was once
>>>>> possible, but not intended, to use 48000 also for TV/Video on saa7134
>>>>> chips, but gave very poor and crackling sound and is wrong.
>>>>> The current saa7134-alsa is simpler to use and also uses an exported
>>>>> mute symbol from saa7134-tvaudio. Default distribution settings are
>>>>> sufficient. On recent Ubutu releases seem to be problems with an out of
>>>>> tree alsa there.
>>>> Ok I'll see with this rate thing and let you know
>>>>> Cheers,
>>>>> Hermann
>>>> Greetings.
>>> I still have nothing with oss and rate=32000, with alsa, or with secam=l
>>> Anyway, some more informations :
>>> * I've got the following error messages on saa7134 module insertion
>>> saa7134_empress: Unknown symbol saa7134_devlist
>>> saa7134_empress: Unknown symbol saa7134_common_ioctl
>>> saa7134_empress: Unknown symbol saa7134_boards
>>> saa7134_empress: Unknown symbol saa7134_ts_register
>>> saa7134_empress: Unknown symbol saa7134_ts_qops
>>> saa7134_empress: Unknown symbol saa7134_i2c_call_clients
>>> saa7134_empress: Unknown symbol saa7134_ts_unregister
>>> saa7134_alsa: Unknown symbol saa7134_tvaudio_setmute
>>> saa7134_alsa: Unknown symbol saa_dsp_writel
>>> saa7134_alsa: Unknown symbol saa7134_devlist
>>> saa7134_alsa: Unknown symbol saa7134_pgtable_alloc
>>> saa7134_alsa: Unknown symbol saa7134_pgtable_build
>>> saa7134_alsa: Unknown symbol saa7134_pgtable_free
>>> saa7134_alsa: Unknown symbol saa7134_dmasound_init
>>> saa7134_alsa: Unknown symbol saa7134_dmasound_exit
>>> saa7134_alsa: Unknown symbol saa7134_set_dmabits
>>> saa7134 ALSA driver for DMA sound loaded
>>> saa7134[0]/alsa: saa7134[0] at 0xe5300000 irq 5 registered as card -1
>>> saa7134[1]/alsa: saa7134[1] at 0xe5301000 irq 9 registered as card -1
>>> * When using audio_debug=1 for saa7134, I've got the following :
>>> saa7134[1]/audio: mute/input: nothing to do [mute=1,input=Television]
>>> saa7134[1]/audio: sound IF not in use, skipping scan
>>> saa7134[1]/audio: mute/input: nothing to do [mute=1,input=Television]
>>> saa7134[1]/audio: mute/input: nothing to do [mute=1,input=Television]
>>> saa7134[1]/audio: ctl_mute=0 automute=0 input=Television  =>  mute=0 
>>> input=Television
>>> saa7134[1]/audio: sound IF not in use, skipping scan
>>> saa7134[1]/audio: mute/input: nothing to do [mute=0,input=Television]
>>> saa7134[1]/audio: sound IF not in use, skipping scan
>>> saa7134[1]/audio: mute/input: nothing to do [mute=0,input=Television]
>>> saa7134[1]/audio: ctl_mute=0 automute=1 input=Television  =>  mute=1 
>>> input=Television
>>> saa7134[1]/audio: sound IF not in use, skipping scan
>>> saa7134[1]/audio: ctl_mute=0 automute=0 input=Television  =>  mute=0 
>>> input=Television
>> Did I mention I'm using ?
> Hi,
> yes, that is the annoying part ;), but still fine, since others have
> been already restless on getting support with latest drivers on a
> 2.4.18 ! without to provide a single line of code themselves ...
> This is completely different with you, but we have other issues too.
> http://linuxtv.org/hg/v4l-dvb/rev/d6660f8c6dbb

I tried that, and yes I have sound with tuner !!!

just using alsa=1 for saa7134

and my HVR is working too (except for sound and tuner but it's another 
thread) so I'll stick to that

many thanks !!!!

> You might try to clean your /media modules and try with that snapshot.
> Not compile tested for 2.6.22, but might fit. Click on bz2 or gz on top.
> Of course, if not auto detected you can select each TV analog standard
> separately for each card you have, but selectable SECAM was new.
> Do you have any progress on it or are you seriously asking me to look at
> a
> You might remember, I'm interested at the point, the encoder gave up.
> Cheers,
> Hermann

CAND Frederic
Product Manager

More information about the linux-dvb mailing list