[linux-dvb] Technotrend S2-3200 Scanning

Faruk A fa at elwak.com
Sun May 18 14:07:50 CEST 2008

> I've managed to get a lock - well no problem there actually, but when I try
> to use mplayer I'm lost:
> $ mplayer /dev/dvb/adapter0/dvr0 (or mplayer -fs /dev/dvb/adapter0/dvr0)
> MPlayer 1.0rc2-4.2.3 (C) 2000-2007 MPlayer Team
> CPU: Intel(R) Core(TM)2 CPU          6600  @ 2.40GHz (Family: 6, Model: 15,
> Stepping: 6)
> CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
> Compiled with runtime CPU detection.
> mplayer: could not connect to socket
> mplayer: No such file or directory
> Failed to open LIRC support. You will not be able to use your remote
> control.
> Playing /dev/dvb/adapter0/dvr0.
> So it says it's playing (the "could not connect to socket" is purely a lirc
> problem) but where's the video?
> I also tried gmplayer, but that just locks up.
> mythtv: there is multiproto patch for mythtv-svn. I tried it but it
> always failed med after 1 hour of compiling it's nothing to do with
> the patch anyway here is the link to the patch.
> http://pansy.at/gernot/mythtv-multiproto-hack.diff.gz
> easiest way is to use vdr, I'm using vdr-1.6.0-1 stable version.
> if you want to use the stable version you have to search for this
> patch [ANNOUNCE] DVB-S2 + H.264 support for VDR-1.5.18 in vdr mailing
> list and patch the vdr source.
> Thanks for the info, I'll be sure to give that a go this evening!

did you run szap with -rp ? make sure the channel you tuned to is not encrypted.

here is another ugly way of doing it.
u need dvbstream and vlc

szap -rp "BBC World"
dvbstream -o | vlc -
or with with mplayer: dvbstream -o | mplayer -

There is two version of dvbstream out there, patched and unpatched.
it should work with both of them, but with multiproto patched version
you dont need to run szap it can tune and lock to channels by it self.

link to the patched version:


More information about the linux-dvb mailing list