[linux-dvb] Technotrend S2-3200 Scanning

Jelle De Loecker skerit at kipdola.com
Sun May 18 14:57:18 CEST 2008

Faruk A schreef:
> did you run szap with -rp ? make sure the channel you tuned to is not encrypted.
> here is another ugly way of doing it.
> u need dvbstream and vlc
> szap -rp "BBC World"
> dvbstream -o | vlc -
> or with with mplayer: dvbstream -o | mplayer -
Very strange,

when I run dvbstream -o, without piping it into anything, I get a lot of 
binary feedback in the console, but I just can't open it in any program. 
(I tuned it using szap2, with the -rp option. I only tried unencrypted 
channels, so no problem there) dvbstream always says "streaming 0 
streams" which is probably not so good.

    $ dvbstream -o | vlc -
    dvbstream will stop after -1 seconds (71582788 minutes)
    Output to stdout
    Streaming 0 streams
    VLC media player 0.8.6e Janus
    libdvdnav: Using dvdnav version 0.1.10 from http://dvd.sf.net
    libdvdread: Using libdvdcss version 1.2.5 for DVD access
    libdvdread: Can't stat -
    No such file or directory
    libdvdnav: vm: faild to open/read the DVD
    libdvbpsi error (PSI decoder): TS discontinuity (received 3,
    expected 0) for PID 0

I even tried to output it to a file, but the file stays blank

    $ dvbstream -o:test.mpg
    Open file test.mpg

    MAP 0, file test.mpg: From -1 secs, To -1 secs, 0 PIDs -
    dvbstream will stop after -1 seconds (71582788 minutes)
    Streaming 0 streams

And when I give mplayer a go I get this:

    $ dvbstream -o | mplayer -
    dvbstream will stop after -1 seconds (71582788 minutes)
    Output to stdout
    Streaming 0 streams
    MPlayer 1.0rc2-4.2.3 (C) 2000-2007 MPlayer Team
    CPU: Intel(R) Core(TM)2 CPU          6600  @ 2.40GHz (Family: 6,
    Model: 15, Stepping: 6)
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled with runtime CPU detection.
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support. You will not be able to use your remote

    Playing -.
    Reading from stdin...
    Cannot seek backward in linear streams!
    Seek failed

Sorry for extensively testing your patience! I, too, wish it would have 
"just worked" :)

Thank you,

Jelle De Loecker
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20080518/e5c35c1c/attachment.htm 

More information about the linux-dvb mailing list