[linux-dvb] CAM of Mantis 2033 still not working

Bas v.d. Wiel bas at kompasmedia.nl
Sat May 31 10:59:16 CEST 2008

On Sat, 31 May 2008 00:10:22 +0400, Manu Abraham <abraham.manu at gmail.com>
> Bas v.d. Wiel wrote:
>> Hi,
>> I'm running 2.6.24-16 64-bit, and I get a whole stream of errors
>> (writing to registers fails) from the frontend whether or not the cam is
>> inserted. I don't get any hard crashes anymore when I insert the CAM,
>> but there's still my previous problem of not being able to find any
>> signal/channels whatsoever using w_scan and a constant stream of 'tuning
>> failure' from dvb-scan. Femon also shows everything as zero values,
>> except the snr ration which is completely maxed out.
> Do you have the LOCK failure problem only when the CAM is inserted ?
> Regards,
> Manu

Hi Manu,
The failures occur regardless of what I do. Whether or not the CAM is
inserted makes no difference at all. I tried it with different Linux
versions (Debian, Mythbuntu, Mythdora) in 32 bit and 64 bit versions. With
the current version of the driver my PC won't unload the mantis module
anymore and therefore refuses to even shut down properly. I'll post a dmesg
output later today. I've been tracking your driver for I guess a little
over a month now. The hard errors and crashes only started to occur after
functionality for the CAM was introduced. Before that the mantis module
loaded properly, it just didn't seem to do anything at all except just sit
there. Using Windows it works fine. A few days ago I posted all the
information I could find about my hardware (simply by looking at it) on the


More information about the linux-dvb mailing list