[linux-dvb] Afatech DVB-T - Installation Guide - v0.1.1j (70% working)

Jelle de Jong jelledejong at powercraft.nl
Tue Oct 14 21:30:19 CEST 2008

Antti Palosaari wrote:
> Jelle de Jong wrote:
>> Antti Palosaari wrote:
>>> hello Jelle,
>>> sorry for top-posting...
>>> Error from attached file:
>>> [   57.163981] DVB: registering frontend 0 (Afatech AF9013 DVB-T)...
>>> [   57.277990] af9015: command failed:2
>>> [   57.278001] mt2060 I2C read failed
>>> goes to the fact that I2C-communication towards tuner is behind I2C-gate 
>>> of the AF9015/AF9013. MT2060 you use does not have I2C-gate implemented. 
>>> Use newer MT2060 module for correct functionality.
>>> See for more information:
>>> http://palosaari.fi/linux/v4l-dvb/controlling_tuner.txt
>>> http://palosaari.fi/linux/v4l-dvb/controlling_tuner_af9015_dual_demod.txt
>>> reagrds
>>> Antti
>> Thanks for the information, since one of my specializations is embedded
>> hardware development, I do understand the presented issues.
>> Should there not be an option to the MT2060 module to use the I2C-gate
>> or not? What can I do to get this device working now?
> There is no option for I2C-gate, gate will be called every time when 
> access to tuner is needed. If you already use MT2060 coming with AF9015 
> driver it should work. I doubt that you are mixing em2880 driver and 
> af9015 and wrong tuner driver is coming from em2880. But I am not sure. 
> Could you make clean install to see whether or not it is working.
> hg clone http://linuxtv.org/hg/v4l-dvb/
> make
> make install (root privileges)
> replug stick
> reboot
> plug stick
> It should work (hopefully)
> reagrds
> Antti

I tried the above but it did not work, so I flushed out my current
kernel and modules and restored it to a default Debian state and rebuild
the af9015 system as described in my attachment.

The device kind of works now (yes :-p), with normal passive antennas I
can find signals, however with my kind of expensive active antenna it
does not find anything... I can also tune the signal with totem-xine
dvb, mplayer is not able to tune the signal... I have no idea why, i
tried different timeout and cache settings.

Also the remote does not work, when the device is connected during boot
nu input device is created. When the device is insert after a complete
boot. the input device is created, but it is not working. I scanned the
event with irrecord without any result...

Playing dvb://Nederland 1(Digitenne).
dvb_tune Freq: 722000000
Not able to lock to the signal on the given frequency, timeout: 1
ERROR, COULDN'T SET CHANNEL  0: Failed to open dvb://Nederland 1(Digitenne).

Any idea's?

Best regards,

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: Afatech DVB-T - Installation Guide - v0.1.2j.txt
Url: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20081014/e5c951b0/attachment-0001.txt 

More information about the linux-dvb mailing list