[linux-dvb] Unresolved symbols

Stefano Sabatini stefano.sabatini-lala at poste.it
Tue Oct 21 00:38:17 CEST 2008

On date Monday 2008-10-20 15:23:22 -0500, Jonathan Johnson wrote:
> Hello all,
>    I have tried to use the drivers and have gotten everything to compile.
> I followed the posted instruction and then........
> I then make "rmmod" and make "insmod" and after the "make insmod" I look at dmesg|more
> It is filled with unresolved symbols.  I have tried rebooting (at nauseam) and no change.
> I have upgraded the kernel and done all the steps all over again with the same results.
> If someone wants to look at about 5 screen fulls of unresolved symbols I can post the relevant parts of dmesg.
> IF any one has any suggestions I will try them and report the results.

You should check:

1) that you're compiling against the same linux headers of the linux
kernel you're using.

Use uname -a to get the linux kernel in use, and verify that the
headers used during compilation are the correct ones. On a
Debian/Ubuntu based system for each pre-compiled linux-image package there is
a corresponding linux-headers package, eventually install it.

2) that you don't have a conflict with some already installed
module. For example I experienced this when installing the v4l-dvb
modules which conflicted with the old standalone gspca module (gspca
V1). Since you can't have both installed you have either to remove the
old module and reinstall the v4l-dvb modules either to remove the
v4l-dvb modules and reinstall the old standalone module.

Unfortunately I think there isn't a make uninstall rule, so I think
the only solution to revert a system is to reinstall the kernel
(easily done with a package management).

HTH, regards.

More information about the linux-dvb mailing list