[linux-dvb] saa7134 bug in 64 bits system

Mathieu Taillefumier mathieu.taillefumier at free.fr
Thu Oct 23 11:43:02 CEST 2008


I did not have much time to further investigate the problem but I tried 
again this time with a kernel and the last hg version of the 
drivers. Here is what I get on 64bits a nice oops with NULL pointers. I 
have to do the test in 32bits kernel (with nearly the same 
configuration, and I know it works on this one) to check if the bug is 
reproducible but since there is already a problem with PCI resources 
allocation I think this bug is the consequence of it.

> at least the device is totally death for any i2c stuff, means that Andy
> is right, that it fails on prior PCI stuff already.
I also think that the problem also comes from pci because I have 
troubles to use my wifi card on the same port. (not both at the same 
time of course)
> Coming up by default with a PCI latency of 0 also looks insane.
> It is also not reproducible on a recent 2.6.26 _64 quad too.
I do not understand your sentence. Are you able to reproduce the bug 
2.6.26 _64 quad or not.
> [Herman]
> Unload the drivers, put the device out, wait 35 seconds, load the
> drivers again, insert that card and report it is still the same.
It does not work on my sony laptop.


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: dmesg-64
Url: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20081023/a367c526/attachment.txt 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.gz
Type: application/gzip
Size: 11605 bytes
Desc: not available
Url : http://www.linuxtv.org/pipermail/linux-dvb/attachments/20081023/a367c526/attachment.bin 

More information about the linux-dvb mailing list