[linux-dvb] [PATCH] cx23885 analog TV and audio support for HVR-1500

Steven Toth stoth at linuxtv.org
Fri Sep 5 15:22:13 CEST 2008

Tim Lucas wrote:
>>  Tim Lucas wrote:
>> > For some reason, when I  add the line
>> > options cx23885 card=6
>> > I can no longer boot the machine successfully.
>> > The machine hangs saying that
>> >
>> > (Ctl-alt-F1)
>> > kinit: No resume image, doing normal boot . . .
>> > (Ctl-alt-F8)
>> > udevd-event[3374]: run-program: '/sbin/modprobe' abnormal exit
>> >
>> > After a while it continues to boot, but the messages go by so fast that I
>> > can't read them.  Finally, it just sits on a blank screen.  Since 
> 2.6.24-19
>> > was originally installed and it updated to 2.6.24-21, I am able to 
> boot into
>> > the older kernel and then comment out that line.
>> >
>> > I am pretty sure that HVR1500 is card 6, so I am not sure what is wrong.
>> >  I didn't have that problem, the first time I rebooted, but have had that
>> > problem on every succesive reboot.
>> >
>> > Any ideas?
>> >
>>  Please cc the list in all email, which I've done.
>>  Check the /var/log/messages or kern.log files to see what they contain.
>>  Or, if the system isn't booting, remove the module from your
>>  /lib/modules/`uname -r`/kernel/drivers/media/video/cx23885 dir then boot
>>  again.
>>  The card won't get initialised by the driver won't exist, then you can
>>  install the driver with 'make install' which will install it from your
>>  linux-dvb/v4l test tree, then load it at your own leisure with modprobe
>>  cx23885 debug=1.
>>  - Steve
> Using your instructions, I figured out that the driver will not load 
> using modprobe. That is why the computer has trouble booting with that 
> driver and the HVR-1500 card selected.
> I also tried copying the relevant code and putting it into the DViCO 
> FusionHDTV7 Dual Express area to see if that worked. I had the same 
> results as when I tried loading the card as a HVR-1500. I cannot get any 
> signal from the card that way.  I know the card is getting a signal 
> because it shows a signal when loaded as a digital card.  If you have 
> any suggestions I would appreciate them.  Thank you.

Why doesn't the driver load if you force it with card=X? What does dmesg 

- Steve

More information about the linux-dvb mailing list