[linux-dvb] DVB USB receiver stopped reporting correct USB ID

Alistair Buxton a.j.buxton at gmail.com
Fri Sep 19 15:59:24 CEST 2008

2008/9/19 Michael <m72 at fenza.com>:
> Hi,
> I have a Kworld USB DVB-T receiver that used to work on Mythbuntu 8.04. The
> driver loaded the firmware correctly (dvb-usb-adstech-usb2-02.fw) and
> everything worked OK.
> Suddenly, without me having made any config changes, it is not being found
> anymore, presumably because it is now reporting a USB ID of 04b4:8613
> [CY7C68013 EZ-USB FX2 USB 2.0 Development Kit].
> When it worked, it used to report an ID of 06e1:a334 [ADS Technologies,
> Inc]. I confirmed the same behavior is the same on another PC (also
> mythbuntu 8.04)
> I think it is not a linux driver problem - the device actually has a
> CY7C68013 in it, so I'm guessing it has somehow "lost" its factory
> configuration that tells it is should present an ID of 06e1:a334.
> Does this mean it is dead or is there some way to reinitialise it?

It is normal for sticks that require firmware loading to have two USB
IDs. The ID changes after the firmware is loaded and the stick goes
into warm mode. EZ-USB is the controller chip that the card is based
on. It looks like the firmware is no longer being loaded for some
reason. Did you do an automatic update of mythbuntu recently? This may
have updated your kernel in which case you might have to copy the
firmware into the firmware directory of the new kernel and/or rename
it and/or recompile and install dvb modules again if you installed
from source. Full dmesg output would be more informative...

Alistair Buxton
a.j.buxton at gmail.com

More information about the linux-dvb mailing list