[linux-dvb] Need help getting the remote of a Nova-T USB-Stick to work

Devin Heitmueller devin.heitmueller at gmail.com
Fri Sep 26 19:27:45 CEST 2008

2008/9/26 Oliver Kleinecke <okleinecke at web.de>:
> I compiled the latest stable v4l-dvb-drivers, everything worked fine, and i`m able to watch tv with kaffeine and mythtv already.
> Now i would like to get the remote to work .. the ir-receiver shows up during boot, giving the following ouput :
> "kernel: input: IR-receiver inside an USB DVB receiver as /class/input/input7".
> If i do a lsinput, the device shows up like this :
> /dev/input/event7
>   bustype : BUS_USB
>   vendor  : 0x2040
>   product : 0x7070
>   version : 256
>   name    : "IR-receiver inside an USB DVB re"
>   phys    : "usb-0001:10:1b.2-1/ir0"
>   bits ev : EV_SYN EV_KEY
> so i`m pretty sure i am not toooo far away from the solution.
> but if i press a button on the rc, it just gives me kernel messages like this :
> "kernel: dib0700: Unknown remote controller key: 1D  2  0  0"
> After a bit of googling, i found out, that there seems to be a solution, using a diff file, which i downloaded already, its attached to this mail.
> Now i need a bit of support in using this diff-file correctly, and some infos on how to continue then..

That patch looks pretty straightforward.  Where did it come from?
Have you tried it out:

cd v4l-dvb
patch -p0 < path_to_patch_file
make install
See if it works...

(or you might have to do "patch -p1", depending on the patch)

If it works for you, it can be checked in so others won't have to deal
with the problem in the future.


Devin J. Heitmueller
AIM: devinheitmueller

More information about the linux-dvb mailing list