[linux-dvb] Asus My Cinema U3000 Mini

Albert Comerma albert.comerma at gmail.com
Mon Jan 5 12:27:20 CET 2009

Just more questions... the v4l driver was already supplied on the kernel or
you downloaded it and compile?
It should not take so much time to get a channel... In other drivers there
was some GPIO problems, but I never got anything similar with this card (at
least nobody told me)...
You can try to load the dvb-core module with a specified timeout in
parameter: dvb_override_tune_delay:0: normal (default), >0 => delay in
milliseconds to wait for lock after a tune attempt (int)

Since you're a beginner in linux you should; first connect your card,
then as root unload the modules used by your card (order is important);
 sudo rmmod dvb_usb_dib0700 dib7000p dib7000m dib3000mc dib0070 dvb_usb
If you want you can get a list on the used modules and dependences between
them running; lsmod | grep dvb
Then you need to reload the modules in opposite order adding the parameter;
sudo modprobe dvb_core dvb_override_tune_delay=10000
You should see the new parameter on
And now you have to finish loadding the other modules one by one; sudo
modprobe dvb_usb... sudo modprobe dib0070...


2009/1/5 Sid Gale <sid at the-gales.com>

> Albert Comerma wrote:
>> Hi Sid, everything looks nice on the dmesg. The usb line numbers depend on
>> the hardware order, so it's not a problem, and the line registering the
>> interface must be there (it's when /dev/dvb is added, so if it's not there
>> you can't comunicate with the device). I think the other usb modules should
>> not give you any problem... If you modified in some way the source code it
>> would be nice to post it, just to have a look. You should also try latest
>> firmware (I think there was a 1.2 version which fixed som i2c problems).
>> And finally I just prefer to use kaffeine that v4l-apps... but that's just
>> a matter of taste.
>> Also try with the small antenna included with the device, I don't manage
>> to get signal from an amplified antenna in linux while the "small and
>> crappy" one works perfectly.
>> 2009/1/3 Sid Gale <sid at the-gales.com <mailto:sid at the-gales.com>>
>>    I'm using the information in the V4L-DVB wiki to try to get an Asus My
>>    Cinema U300 mini usb dvb-t tuner working with eeebuntu (based on Ubuntu
>>    Intrepid) on an eeepc 900. I have these lines in kern.log:
>>    -----------------------------------------------------
>>    Jan  2 13:24:22 sid-eee900 kernel: [   89.624051] usb 1-4: new high
>>    speed USB device using ehci_hcd and address 3
>>    Jan  2 13:24:22 sid-eee900 kernel: [   89.764082] usb 1-4:
>> configuration
>>    #1 chosen from 1 choice
>>    Jan  2 13:24:22 sid-eee900 kernel: [   90.033966] dib0700: loaded with
>>    support for 7 different device-types
>>    Jan  2 13:24:22 sid-eee900 kernel: [   90.035234] dvb-usb: found a
>> 'ASUS
>>    My Cinema U3000 Mini DVBT Tuner' in cold state, will try to load a
>>    firmware
>>    Jan  2 13:24:22 sid-eee900 kernel: [   90.035247] firmware: requesting
>>    dvb-usb-dib0700-1.10.fw
>>    Jan  2 13:24:22 sid-eee900 kernel: [   90.047706] dvb-usb: downloading
>>    firmware from file 'dvb-usb-dib0700-1.10.fw'
>>    Jan  2 13:24:22 sid-eee900 kernel: [   90.254492] dib0700: firmware
>>    started successfully.
>>    Jan  2 13:24:23 sid-eee900 kernel: [   90.756174] dvb-usb: found a
>> 'ASUS
>>    My Cinema U3000 Mini DVBT Tuner' in warm state.
>>    Jan  2 13:24:23 sid-eee900 kernel: [   90.756733] dvb-usb: will pass
>> the
>>    complete MPEG2 transport stream to the software demuxer.
>>    Jan  2 13:24:23 sid-eee900 kernel: [   90.757305] DVB: registering new
>>    adapter (ASUS My Cinema U3000 Mini DVBT Tuner)
>>    Jan  2 13:24:23 sid-eee900 kernel: [   91.080958] DVB: registering
>>    frontend 0 (DiBcom 7000PC)...
>>    Jan  2 13:24:23 sid-eee900 kernel: [   91.190399] MT2266: successfully
>>    identified
>>    Jan  2 13:24:23 sid-eee900 kernel: [   91.350822] dvb-usb: ASUS My
>>    Cinema U3000 Mini DVBT Tuner successfully initialized and connected.
>>    Jan  2 13:24:23 sid-eee900 kernel: [   91.353100] usbcore: registered
>>    new interface driver dvb_usb_dib0700
>>    ---------------------------------------------
>>    These match the information given in the wiki for 'Successful
>>    initialization' except for the usb 'number' and address (1-4 and 3 for
>>    me, 5-7 and 8 in the wiki) and the very last line 'usbcore: registered
>>    new interface driver dvb_usb_dib0700'. This last line does not appear
>> in
>>    the wiki entry for 'Successful initialization' but does appear in the
>>    two of the 'failure' entries.
>>    When I try to scan for channels, using the dvb_apps package as
>> described
>>    in the wiki, I get this:
>>    ------------------------------------
>>    scanning /usr/share/doc/dvb-utils/examples/scan/dvb-t/uk-Oxford
>>    using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
>>    initial transponder 578000000 0 2 9 3 0 0 0
>>     >>> tune to:
>>    WARNING: filter timeout pid 0x0011
>>    WARNING: filter timeout pid 0x0000
>>    WARNING: filter timeout pid 0x0010
>>    dumping lists (0 services)
>>    Done.
>>    --------------------------------------
>>    The tuner is connected to a roof-mounted aerial and when plugged in to
>> a
>>    Windows system pulls in 35 channels.
>>    I'm very new to Linux and have no idea how to proceed, so I was hoping
>>    that someone here could give me some pointers. I have noticed that in
>>    the dmesg file there are lines saying:
>>    -----------------------
>>    Warning! ehci_hcd should always be loaded before uhci_hcd and ohci_hcd,
>>    not after
>>    ------------------------
>>    All the lines referring to ehci_hcd do, in fact, come after the
>> ohci_hcd
>>    lines so it would appear that I have the order wrong. Would this make a
>>    difference and, if so, how do I correct it?
>>    I'd be very grateful for any help anyone can offer.
> Hi Albert
> Thanks for your reply. I've tried the new firmware and with the supplied
> aerial, but with no different results. I haven't changed any source code -
> at present I wouldn't know how, I'm still learning. I understand, though,
> that the eeebuntu kernel is a modified one called the array kernel, if that
> makes any difference. I tried Kaffine and Me TV first and found that neither
> could detect any channels, which is why I decided to try the dvb utilities
> from the wiki. Thanks for the suggestions, though.
> Can anyone give me some advice on how to find out why I get the 'filter
> timeout'? Is it because there is no filter to be found, or because there is
> no signal from the tuner, or because no channels are found within a given
> time...? If it's the last of these then it isn't trying for long enough, as
> it takes a minute of so for the first channel to be found on a Windows
> system and the filter timeout occurs after a few seconds.
> Regards
> Sid
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20090105/28ad89dd/attachment.htm 

More information about the linux-dvb mailing list