[linux-dvb] KNC1

Rasmus Pedersen rasmus at akvaservice.dk
Wed Mar 11 00:19:47 CET 2009


I've got some problems getting my KNC1 DVB-C working correctly.

The card is found correctly as

DVB: registering new adapter (KNC1 DVB-C MK3)
DVB: registering adapter 0 frontend 0 (Philips TDA10023 DVB-C)

I also have a CAM connected with an irdeto card installed. Syslog tells
me that its been succesfullay detected.

dvb_ca adapter 0: DVB CAM detected and initialised successfully

I can view non-encrypted/encrypted channels when using Kaffeine,
everything is working perfectly. 

My problem is that I want to record tv from the consol (I'm working on
script that can record television and expose it thru mediatomb to be
played on my PS3), and Kaffeine does not run without its UI.

I have tried mplayer and xine, but I quickly found that neither of them
has the abilty to decrypt using the attached CAM. So I went onto try
gnutv, and thats where my problems really start.

When I start gnutv like this.

./gnutv -caslotnum 0 -out file test.ts -channels channels.conf "Kanal 5"

I get this error in syslog.

DVB: TDA10023(0): tda10023_writereg, writereg error (reg == 0x2a, val ==
0x02, ret == -121)

gnutv outputs this to console:

CAM Application type: 01
CAM Application manufacturer: cafe
CAM Manufacturer code: babe
CAM Menu string: Irdeto Access

And nothing else.

The stream saved to test.ts has no video, so I presume gnutv does not
decrypt the video stream.

./gnutv -cammenu works fine, and I can access the cam information using

The problem is also there when using zap and dvbstreamer. I have not yet
tried mythtv or vdr, since I was hoping for a simpler solution using
gnutv or similar software to just dump the stream to disk (decrypted

I have installed latest v4l drivers from CSV and alos latest dvbapps
from CSV.

I hope somebody might now what the problem could be..

Rasmus Pedersen

More information about the linux-dvb mailing list