[linux-dvb] rtl2831-r2 still not working for Compro VideoMate U80

Ugnius Soraka spam.ugnius40 at gmail.com
Sun Oct 10 01:59:16 CEST 2010


I'd like to get in touch with driver developers, is there any way I
could help make RTL2831U driver work with Compro VideoMate U80. I would
like to actively participate. My programming skills are well below
required to write kernel modules, so I know I would be no use there. But
anything else, testing with VideoMate U80, sending debug logs, I think I
could do that.

I've tried http://linuxtv.org/hg/~jhoogenraad/rtl2831-r2 driver, it
looked promising. U80 device was recognised as VideoMate U90, /dev/dvb
entries were created. But when scanning it says there's no signal. Debug
gives TPS_NON_LOCK, Signal NOT Present, rtd2830_soft_reset, etc. (I
could post message log, if it's any use to somebody).
U80 has a led which (on windows) shows if TV stick is tuned in and
working, when scanning on linux it's always on.

I've also tried to compile http://linuxtv.org/hg/~anttip/rtl2831u/ but
for now it's based on old dvb tree and seems to be incompatible with new
kernels (mine

Is anttip driver supposed to be included in kernel, but it looks like
development is going slow.

Thank you,

More information about the linux-dvb mailing list